summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/slime/slime-2.11.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/slime/slime-2.11.ebuild')
-rw-r--r--app-emacs/slime/slime-2.11.ebuild122
1 files changed, 122 insertions, 0 deletions
diff --git a/app-emacs/slime/slime-2.11.ebuild b/app-emacs/slime/slime-2.11.ebuild
new file mode 100644
index 000000000000..effd2445cafc
--- /dev/null
+++ b/app-emacs/slime/slime-2.11.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+[[ ${PV} = *9999* ]] && GIT_ECLASS="git-r3" || GIT_ECLASS=""
+
+inherit common-lisp-3 ${GIT_ECLASS} elisp eutils
+
+DESCRIPTION="SLIME, the Superior Lisp Interaction Mode (Extended)"
+HOMEPAGE="http://common-lisp.net/project/slime/"
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="https://github.com/slime/slime/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="GPL-2 xref? ( xref.lisp )"
+SLOT="0"
+if [[ ${PV} == *9999* ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+fi
+IUSE="doc xref"
+RESTRICT=test # tests fail to contact sbcl
+
+RDEPEND="virtual/commonlisp
+ dev-lisp/asdf"
+DEPEND="${RDEPEND}
+ >=sys-apps/texinfo-5.1
+ doc? ( virtual/texi2dvi )"
+
+CLPACKAGE=swank
+CLSYSTEMS=swank
+SITEFILE=70${PN}-gentoo.el
+
+src_unpack() {
+ if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/slime/slime.git"
+ ${GIT_ECLASS}_src_unpack
+ fi
+ elisp_src_unpack
+}
+
+src_prepare() {
+ if [[ "${PV}" == "2.11" ]]; then
+ epatch "${FILESDIR}"/2.11/dont-load-sbcl-pprint.patch
+ fi
+ epatch "${FILESDIR}"/2.0_p20130214/gentoo-module-load.patch
+ epatch "${FILESDIR}"/2.0_p20110617/gentoo-dont-call-init.patch
+ has_version ">=app-editors/emacs-24" && rm -f lib/cl-lib.el
+
+ # extract date of last update from ChangeLog, bug 233270
+ SLIME_CHANGELOG_DATE=$(awk '/^[-0-9]+ / { print $1; exit; }' ChangeLog)
+ [ -n "${SLIME_CHANGELOG_DATE}" ] || die "cannot determine ChangeLog date"
+
+ # SLIME uses the changelog date to make sure that the emacs side and the CL side
+ # are in sync. We hardcode it instead of letting slime determine it at runtime
+ # because ChangeLog doesn't get installed to $EMACSDIR
+ epatch "${FILESDIR}"/2.11/gentoo-changelog-date.patch
+
+ # When starting slime in emacs, slime looks for ${S}/swank/backend.lisp as
+ # /usr/share/common-lisp/source/swank/swank-backend.lisp
+ pushd swank || die
+ for i in *.lisp
+ do
+ mv ${i} ../swank-${i}
+ done
+ popd
+
+ sed -i "/(defvar \*swank-wire-protocol-version\*/s:nil:\"${SLIME_CHANGELOG_DATE}\":" swank.lisp \
+ || die "sed swank.lisp failed"
+ sed -i "s:@SLIME-CHANGELOG-DATE@:${SLIME_CHANGELOG_DATE}:" slime.el \
+ || die "sed slime.el failed"
+ sed -i "s/@itemx INIT-FUNCTION/@item INIT-FUNCTION/" doc/slime.texi \
+ || die "sed doc/slime.texi failed"
+
+ # Remove xref.lisp (which is non-free) unless USE flag is set
+ use xref || rm -f xref.lisp
+}
+
+src_compile() {
+ elisp-compile *.el || die
+ BYTECOMPFLAGS="${BYTECOMPFLAGS} -L contrib -l slime" \
+ elisp-compile contrib/*.el lib/*.el || die
+ emake -j1 -C doc slime.info || die "Cannot build info docs"
+
+ if use doc; then
+ VARTEXFONTS="${T}"/fonts \
+ emake -j1 -C doc slime.pdf || die "emake doc failed"
+ fi
+}
+
+src_install() {
+ ## install core
+ elisp-install ${PN} *.{el,elc} "${FILESDIR}"/swank-loader.lisp \
+ || die "Cannot install SLIME core"
+ sed "s:/usr/:${EPREFIX}&:g" "${FILESDIR}"/2.0_p20110617/${SITEFILE} \
+ >"${T}"/${SITEFILE} || die "sed failed"
+ elisp-site-file-install "${T}"/${SITEFILE} || die
+ cp "${FILESDIR}"/2.0_p20110617/swank.asd "${S}"
+ # remove upstream swank-loader, since it won't be used
+ rm "${S}"/swank-loader.lisp
+ common-lisp-install-sources *.lisp
+ common-lisp-install-asdf swank.asd
+
+ ## install contribs
+ elisp-install ${PN}/contrib/ contrib/*.{el,elc,scm,goo} \
+ || die "Cannot install contribs"
+ common-lisp-install-sources contrib/*.lisp
+
+ ## install lib
+ elisp-install ${PN}/lib/ lib/*.{el,elc} \
+ || die "Cannot install libs"
+
+ ## install docs
+ dodoc README.md ChangeLog CONTRIBUTING.md NEWS PROBLEMS
+ newdoc contrib/README.md README-contrib.md
+ newdoc contrib/ChangeLog ChangeLog.contrib
+ doinfo doc/slime.info
+ use doc && dodoc doc/*.pdf
+}