summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-10-16 18:13:36 +0200
committerUlrich Müller <ulm@gentoo.org>2019-10-16 18:58:47 +0200
commit4215e7923527132b4c59a13f5473fa2b6943c08b (patch)
tree6450b50e3c7b31339cd4e6270c3cb168085079a2 /app-emacs/sml-mode/sml-mode-6.9.ebuild
parentapp-emacs/matlab: New snapshot. (diff)
downloadgentoo-4215e7923527132b4c59a13f5473fa2b6943c08b.tar.gz
gentoo-4215e7923527132b4c59a13f5473fa2b6943c08b.tar.bz2
gentoo-4215e7923527132b4c59a13f5473fa2b6943c08b.zip
app-emacs/sml-mode: Bump to version 6.9.
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/sml-mode/sml-mode-6.9.ebuild')
-rw-r--r--app-emacs/sml-mode/sml-mode-6.9.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/sml-mode/sml-mode-6.9.ebuild b/app-emacs/sml-mode/sml-mode-6.9.ebuild
new file mode 100644
index 000000000000..dd9b5fb272ab
--- /dev/null
+++ b/app-emacs/sml-mode/sml-mode-6.9.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Emacs major mode for editing Standard ML"
+HOMEPAGE="https://elpa.gnu.org/packages/sml-mode.html
+ http://www.iro.umontreal.ca/~monnier/elisp/"
+# taken from https://elpa.gnu.org/packages/${P}.el
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+
+SITEFILE="50${PN}-gentoo-6.1.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}