summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-10-06 11:25:18 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-10-06 17:20:46 +0200
commit3005e2b919d40703e8373567fdd880804606f124 (patch)
treed9800afb843bba5f106b31c35d4ab1a7260d2ba0 /app-emacs/swift-mode/swift-mode-9.1.0.ebuild
parentapp-emacs/swift-mode: drop old 8.6.0 (diff)
downloadgentoo-3005e2b919d40703e8373567fdd880804606f124.tar.gz
gentoo-3005e2b919d40703e8373567fdd880804606f124.tar.bz2
gentoo-3005e2b919d40703e8373567fdd880804606f124.zip
app-emacs/swift-mode: bump to 9.1.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/swift-mode/swift-mode-9.1.0.ebuild')
-rw-r--r--app-emacs/swift-mode/swift-mode-9.1.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-emacs/swift-mode/swift-mode-9.1.0.ebuild b/app-emacs/swift-mode/swift-mode-9.1.0.ebuild
new file mode 100644
index 000000000000..3c78d0b5123e
--- /dev/null
+++ b/app-emacs/swift-mode/swift-mode-9.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs support for Apple's Swift programming language"
+HOMEPAGE="https://github.com/swift-emacs/swift-mode/"
+SRC_URI="https://github.com/swift-emacs/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md CONTRIBUTING.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} \
+ -L . -L test \
+ -l test/swift-mode-test.el \
+ -f swift-mode:run-test || die "tests failed"
+}