summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-12-03 07:47:03 +0100
committerHans de Graaff <graaff@gentoo.org>2021-12-03 07:47:03 +0100
commit669188954675489271ac979181613e90dcc4ad19 (patch)
tree3569657509407389d0ef4dedf8c8478b78da1afd /app-emacs/transient/transient-0.3.7.ebuild
parentapp-emacs/transient: cleanup (diff)
downloadgentoo-669188954675489271ac979181613e90dcc4ad19.tar.gz
gentoo-669188954675489271ac979181613e90dcc4ad19.tar.bz2
gentoo-669188954675489271ac979181613e90dcc4ad19.zip
app-emacs/transient: add 0.3.7
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'app-emacs/transient/transient-0.3.7.ebuild')
-rw-r--r--app-emacs/transient/transient-0.3.7.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/transient/transient-0.3.7.ebuild b/app-emacs/transient/transient-0.3.7.ebuild
new file mode 100644
index 000000000000..a23829397b0b
--- /dev/null
+++ b/app-emacs/transient/transient-0.3.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="Use the Emacsclient as the \$EDITOR of child processes"
+HOMEPAGE="https://magit.vc/manual/transient"
+SRC_URI="https://github.com/magit/transient/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="docs/*.texi"
+DOCS="README.md docs/transient.org"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} sys-apps/texinfo"
+
+src_prepare() {
+ mv lisp/*.el . || die
+
+ default
+}