summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-11 12:37:27 +0100
committerSam James <sam@gentoo.org>2023-10-11 12:37:27 +0100
commitcfa01cfb12af31e1a18c4f054e2eb3880ad562ec (patch)
tree79789e16694a2ed59a82a4633fcfbb2080692fde /app-emacs/treesit-auto/treesit-auto-0.6.4.ebuild
parentapp-emacs/treesit-auto: keyword 0.6.3 for ~amd64 (diff)
downloadgentoo-cfa01cfb12af31e1a18c4f054e2eb3880ad562ec.tar.gz
gentoo-cfa01cfb12af31e1a18c4f054e2eb3880ad562ec.tar.bz2
gentoo-cfa01cfb12af31e1a18c4f054e2eb3880ad562ec.zip
app-emacs/treesit-auto: add 0.6.4
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emacs/treesit-auto/treesit-auto-0.6.4.ebuild')
-rw-r--r--app-emacs/treesit-auto/treesit-auto-0.6.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/treesit-auto/treesit-auto-0.6.4.ebuild b/app-emacs/treesit-auto/treesit-auto-0.6.4.ebuild
new file mode 100644
index 000000000000..568eeea9b6f6
--- /dev/null
+++ b/app-emacs/treesit-auto/treesit-auto-0.6.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=29
+inherit elisp
+
+DESCRIPTION="Automatic installation, usage, fallback for tree-sitter modes in Emacs 29"
+HOMEPAGE="https://github.com/renzmann/treesit-auto"
+
+if [[ ${PV} == *_p* ]] ; then
+ MY_COMMIT=""
+ SRC_URI="https://github.com/renzmann/treesit-auto/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${MY_COMMIT}
+else
+ SRC_URI="https://github.com/renzmann/treesit-auto/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+SITEFILE="50${PN}-gentoo.el"