summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-26 03:34:40 +0100
committerSam James <sam@gentoo.org>2023-03-26 03:35:10 +0100
commitede594fc156724728e8786399c04a88ed32def63 (patch)
tree23685886c57e14a9c152c93c2935a1aac3185d5a /app-emacs/treesit-auto
parentdev-cpp/curlpp: Stabilize 0.8.1 amd64, #903071 (diff)
downloadgentoo-ede594fc156724728e8786399c04a88ed32def63.tar.gz
gentoo-ede594fc156724728e8786399c04a88ed32def63.tar.bz2
gentoo-ede594fc156724728e8786399c04a88ed32def63.zip
app-emacs/treesit-auto: new package, add 0.6.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emacs/treesit-auto')
-rw-r--r--app-emacs/treesit-auto/Manifest1
-rw-r--r--app-emacs/treesit-auto/files/50treesit-auto-gentoo.el1
-rw-r--r--app-emacs/treesit-auto/metadata.xml16
-rw-r--r--app-emacs/treesit-auto/treesit-auto-0.6.3.ebuild25
4 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/treesit-auto/Manifest b/app-emacs/treesit-auto/Manifest
new file mode 100644
index 000000000000..64b8c6ac71e5
--- /dev/null
+++ b/app-emacs/treesit-auto/Manifest
@@ -0,0 +1 @@
+DIST treesit-auto-0.6.3.tar.gz 21342 BLAKE2B 291b9c5706cf0a6e329d9be12b89f7cb3b3c9eed7792bec0b0842785a167f053cac3672516adeefc09a81eb7126f7cee8b63810271566dcc93bd6b04ad41f0c5 SHA512 d4dfc081aa632b4582a91c99103afb9ffd11db56d58fa3a9d6693372b640b163d08bd3a2ce7cb384600357dddee02f6c0a73bf940fd4117f01f70811a311d140
diff --git a/app-emacs/treesit-auto/files/50treesit-auto-gentoo.el b/app-emacs/treesit-auto/files/50treesit-auto-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/treesit-auto/files/50treesit-auto-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/treesit-auto/metadata.xml b/app-emacs/treesit-auto/metadata.xml
new file mode 100644
index 000000000000..95a10fb31665
--- /dev/null
+++ b/app-emacs/treesit-auto/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/renzmann/treesit-auto/issues/</bugs-to>
+ <remote-id type="github">renzmann/treesit-auto</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/treesit-auto/treesit-auto-0.6.3.ebuild b/app-emacs/treesit-auto/treesit-auto-0.6.3.ebuild
new file mode 100644
index 000000000000..e00a9e82638e
--- /dev/null
+++ b/app-emacs/treesit-auto/treesit-auto-0.6.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=29
+inherit elisp
+
+DESCRIPTION="Automatic installation, usage, and fallback for tree-sitter major modes in Emacs 29"
+HOMEPAGE="https://github.com/renzmann/treesit-auto"
+
+if [[ ${PV} == *_p* ]] ; then
+ MY_COMMIT=""
+ SRC_URI="https://github.com/renzmann/treesit-auto/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${MY_COMMIT}
+else
+ SRC_URI="https://github.com/renzmann/treesit-auto/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+# Needs Emacs 29
+#KEYWORDS="~amd64"
+
+SITEFILE="50${PN}-gentoo.el"