summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Mackdanz <stasibear@gentoo.org>2018-07-27 21:22:15 -0500
committerErik Mackdanz <stasibear@gentoo.org>2018-07-27 21:22:15 -0500
commit885f6d4e38e407a5b3843cb4bb4dd8a8cdf86178 (patch)
treec6168aae2661b8067565dbb5926e161fce9d2681 /app-emacs/wanderlust
parentapp-emacs/apel: Fix brace issue, EAPI 6 (diff)
downloadgentoo-885f6d4e38e407a5b3843cb4bb4dd8a8cdf86178.tar.gz
gentoo-885f6d4e38e407a5b3843cb4bb4dd8a8cdf86178.tar.bz2
gentoo-885f6d4e38e407a5b3843cb4bb4dd8a8cdf86178.zip
app-emacs/wanderlust: Fix error about default-truncate-lines
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'app-emacs/wanderlust')
-rw-r--r--app-emacs/wanderlust/files/wanderlust-2.15.9_p20130619-default-truncate-lines.patch17
-rw-r--r--app-emacs/wanderlust/wanderlust-2.15.9_p20130619.ebuild5
2 files changed, 20 insertions, 2 deletions
diff --git a/app-emacs/wanderlust/files/wanderlust-2.15.9_p20130619-default-truncate-lines.patch b/app-emacs/wanderlust/files/wanderlust-2.15.9_p20130619-default-truncate-lines.patch
new file mode 100644
index 000000000000..d6da446cc84a
--- /dev/null
+++ b/app-emacs/wanderlust/files/wanderlust-2.15.9_p20130619-default-truncate-lines.patch
@@ -0,0 +1,17 @@
+--- a/wl/wl-vars.el.orig 2018-07-27 21:05:15.768467090 -0500
++++ b/wl/wl-vars.el 2018-07-27 21:05:45.590468576 -0500
+@@ -1742,12 +1742,12 @@
+ :group 'wl-pref
+ :type 'string)
+
+-(defcustom wl-message-truncate-lines default-truncate-lines
++(defcustom wl-message-truncate-lines nil
+ "*Truncate lines in Message Buffer."
+ :type 'boolean
+ :group 'wl-pref)
+
+-(defcustom wl-draft-truncate-lines default-truncate-lines
++(defcustom wl-draft-truncate-lines nil
+ "*Truncate lines in Draft Buffer."
+ :type 'boolean
+ :group 'wl-draft
diff --git a/app-emacs/wanderlust/wanderlust-2.15.9_p20130619.ebuild b/app-emacs/wanderlust/wanderlust-2.15.9_p20130619.ebuild
index 2f035471caad..51d5a4750a4c 100644
--- a/app-emacs/wanderlust/wanderlust-2.15.9_p20130619.ebuild
+++ b/app-emacs/wanderlust/wanderlust-2.15.9_p20130619.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit elisp
@@ -22,6 +22,7 @@ DEPEND=">=app-emacs/apel-10.6
RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}"
+ELISP_PATCHES="${P}-default-truncate-lines.patch"
SITEFILE="50${PN}-gentoo.el"
src_configure() {