summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-07-20 22:43:31 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-07-20 22:43:31 +0900
commitb417eee35105f6514e13c8e33061d1d1a1b06faa (patch)
tree3386c0caa18954c40874cfb6150428f931e17a1a /app-emacs/yc/yc-5.2.1.ebuild
parentapp-emacs/yc: update to EAPI 6 (diff)
downloadgentoo-b417eee35105f6514e13c8e33061d1d1a1b06faa.tar.gz
gentoo-b417eee35105f6514e13c8e33061d1d1a1b06faa.tar.bz2
gentoo-b417eee35105f6514e13c8e33061d1d1a1b06faa.zip
app-emacs/yc: new upstream release
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-emacs/yc/yc-5.2.1.ebuild')
-rw-r--r--app-emacs/yc/yc-5.2.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-emacs/yc/yc-5.2.1.ebuild b/app-emacs/yc/yc-5.2.1.ebuild
new file mode 100644
index 000000000000..eb6992a1aa20
--- /dev/null
+++ b/app-emacs/yc/yc-5.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit elisp
+
+DESCRIPTION="Yet another Canna client on Emacsen"
+HOMEPAGE="http://www.ceres.dti.ne.jp/~knak/yc.html"
+SRC_URI="http://www.ceres.dti.ne.jp/~knak/${P}.el.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="app-i18n/canna"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+
+ dodoc "${FILESDIR}"/sample.{dot.emacs,hosts.canna}
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ elog "See the sample.dot.emacs in ${EPREFIX}/usr/share/doc/${PF}."
+ elog
+ elog "And If you use unix domain socket for connecting the canna server,"
+ elog "please confirm that there's *no* following line in your ~/.emacs:"
+ elog ' (setq yc-server-host "localhost")'
+ elog
+ elog "If you use inet domain socket for connecting the canna server,"
+ elog "please modify as following in ${EPREFIX}/etc/conf.d/canna:"
+ elog ' CANNASERVER_OPTS="-inet"'
+ elog
+ elog "And create ${EPREFIX}/etc/hosts.canna."
+ elog "See the sample.hosts.canna in ${EPREFIX}/usr/share/doc/${PF}."
+}