summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-02-14 17:10:38 +0000
committerMatthew Smith <matthew@gentoo.org>2022-02-14 17:21:32 +0000
commit14a17c9f7d8fc7dafeb1a733632323928e66a656 (patch)
tree19c85f9f483c6f985354b0e3308ffab9d01ba719 /app-emacs
parentapp-emacs/undo-tree: add gitlab upstream metadata (diff)
downloadgentoo-14a17c9f7d8fc7dafeb1a733632323928e66a656.tar.gz
gentoo-14a17c9f7d8fc7dafeb1a733632323928e66a656.tar.bz2
gentoo-14a17c9f7d8fc7dafeb1a733632323928e66a656.zip
app-emacs/queue: initial import at 0.2
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/queue/Manifest1
-rw-r--r--app-emacs/queue/files/50queue-gentoo.el1
-rw-r--r--app-emacs/queue/metadata.xml16
-rw-r--r--app-emacs/queue/queue-0.2.ebuild17
4 files changed, 35 insertions, 0 deletions
diff --git a/app-emacs/queue/Manifest b/app-emacs/queue/Manifest
new file mode 100644
index 000000000000..5713634b317b
--- /dev/null
+++ b/app-emacs/queue/Manifest
@@ -0,0 +1 @@
+DIST queue-0.2.el.xz 2168 BLAKE2B 4c6c89ffa66d1bc5da11b78b6965077922384090327360c5b787508d9248051a6e3371b1e6ae5dd0fc8337d4623cbcb07d44d0f6147b29f14da8a3900868bd94 SHA512 62e43482db9828fe6f6d58c95389cd93642a6019211b190dd8f862efa6011708ad8e9a6c025ddb2e663effe0a8aec2f72f42f1afcaaf4c7d64fe698c274eef39
diff --git a/app-emacs/queue/files/50queue-gentoo.el b/app-emacs/queue/files/50queue-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/queue/files/50queue-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/queue/metadata.xml b/app-emacs/queue/metadata.xml
new file mode 100644
index 000000000000..3ac8e09b5ce7
--- /dev/null
+++ b/app-emacs/queue/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Provides queues can be used both as a first-in last-out (FILO) and
+ as a first-in first-out (FIFO) stack, i.e. elements can be added to
+ the front or back of the queue, and can be removed from the
+ front. (This type of data structure is sometimes called an
+ "output-restricted deque".)
+ </longdescription>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/app-emacs/queue/queue-0.2.ebuild b/app-emacs/queue/queue-0.2.ebuild
new file mode 100644
index 000000000000..08989ce08bb2
--- /dev/null
+++ b/app-emacs/queue/queue-0.2.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Queue data structure"
+HOMEPAGE="https://elpa.gnu.org/packages/queue.html"
+SRC_URI="https://dev.gentoo.org/~matthew/distfiles/${P}.el.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"