summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-02-02 18:32:32 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-02-02 18:46:44 +0100
commit1adad85124c9d1e67be104d550b0898acaa3885d (patch)
tree30c3a9d3d420b8cd39e7ac71e3c8367c3fb3d941 /app-emacs
parentnet-misc/netifrc: drop obsolete udev blocker (diff)
downloadgentoo-1adad85124c9d1e67be104d550b0898acaa3885d.tar.gz
gentoo-1adad85124c9d1e67be104d550b0898acaa3885d.tar.bz2
gentoo-1adad85124c9d1e67be104d550b0898acaa3885d.zip
app-emacs/compat: bump to 29.1.3.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/compat/Manifest1
-rw-r--r--app-emacs/compat/compat-29.1.3.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emacs/compat/Manifest b/app-emacs/compat/Manifest
index 41972213b082..d2a85fa99669 100644
--- a/app-emacs/compat/Manifest
+++ b/app-emacs/compat/Manifest
@@ -3,3 +3,4 @@ DIST compat-28.1.2.2.tar.gz 82479 BLAKE2B 154104a3d1cf953f712de357d21736d648289d
DIST compat-29.1.1.0.tar.gz 94072 BLAKE2B 675f0bbf4411fb0d2c2e8f77bcd62dbe56da1f052bd6e390dade0c8075eaa480bb387280a29ae09396a2f4bf27746ae1065d38dd1b7882b9c8c0ec3a4eb776e5 SHA512 5c7b093314cd8f8d8cbab4f470a64d3f104d0e79d2881f2f2309700c6fe5f58a72a8a65379868edba33c0b6af1d43f1474e2fefc65c033f39981d29fca35259a
DIST compat-29.1.3.0.tar.gz 111711 BLAKE2B 7a9b104baf141136e91a49e4697e0add3da64cf979354c25c7798c9a8f1b91796e774f262fc306a12c4c03d918089ca9af48471ab62bb0f02a890969f54104e7 SHA512 5724855f0572b33bd96ea0dfa85eac3b64f6c5be58edc2b14d474295d0b0cd86a0e71d704907aed37d1bb254be938e98ef15323cae590ca10cd072b94d3f25c2
DIST compat-29.1.3.1.tar.gz 112748 BLAKE2B d7e3d5e28931857f28d564bd03cb3ebfb3e6d0fa503843b425583950b9473cee9676ddb571af4f788a016ea42eace06a317dc4bf967556d85e50cb5d26097c62 SHA512 bde4ee9d3ba813fddf5db9f91e1211e5aa4d678a31e8bd4904ba9e94d66efad90fa0ce39583925121761b25ff197d26370412ef927ecad6ee9bea0f49ec41555
+DIST compat-29.1.3.2.tar.gz 117624 BLAKE2B 340f9e5c31770370e1a7320c31d81bcd5e723c80fd1e178f852dfc4213c48387364b7ef05babd3a46fd71943d4c1c88ab76911d509be69b0993cf6e81f36abc2 SHA512 f5b16ebad7b9701548d605d2e015c8ced65c374ae8ab87e9c34a64be9f018ef909c6b775e7df0ce3b92827c7556a1f754a300ed25db1f3c6299a63f17694d08d
diff --git a/app-emacs/compat/compat-29.1.3.2.ebuild b/app-emacs/compat/compat-29.1.3.2.ebuild
new file mode 100644
index 000000000000..459edf66eea1
--- /dev/null
+++ b/app-emacs/compat/compat-29.1.3.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.4
+
+inherit elisp
+
+DESCRIPTION="Compatibility libraries for Emacs"
+HOMEPAGE="https://github.com/emacs-compat/compat/
+ https://git.sr.ht/~pkal/compat/"
+SRC_URI="https://github.com/emacs-compat/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+BDEPEND="sys-apps/texinfo"
+
+ELISP_TEXINFO="${PN}.texi"
+
+src_compile() {
+ emake compile ${PN}.info
+}
+
+src_test() {
+ local has_json="$("${EMACS}" ${EMACSFLAGS} --eval "(princ (fboundp 'json-parse-string))")"
+ if [[ "${has_json}" != t ]] ; then
+ local line
+ while read line ; do
+ ewarn "${line}"
+ done <<-EOF
+ Your current Emacs version does not support native JSON parsing,
+ which is required for running tests of ${CATEGORY}/${PN}.
+ Emerge >=app-editors/emacs-27 with USE="json" and use "eselect emacs"
+ to select that version.
+ EOF
+ else
+ emake test
+ fi
+}