summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-05-04 14:51:59 +0200
committerUlrich Müller <ulm@gentoo.org>2019-05-04 15:33:39 +0200
commit2b454725d9d5795f06be5713428ee70516475d2d (patch)
treefba4608b73363c63a7bd684f7fa413a20c0de8b9 /app-emacs
parentapp-emacs/async: Initial import. (diff)
downloadgentoo-2b454725d9d5795f06be5713428ee70516475d2d.tar.gz
gentoo-2b454725d9d5795f06be5713428ee70516475d2d.tar.bz2
gentoo-2b454725d9d5795f06be5713428ee70516475d2d.zip
app-emacs/helm: Initial import.
This is the successor to app-emacs/anything, according to https://www.emacswiki.org/emacs/Anything. Ebuild contributed by me. Package-Manager: Portage-2.3.65, Repoman-2.3.12 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/helm/Manifest1
-rw-r--r--app-emacs/helm/files/50helm-gentoo.el2
-rw-r--r--app-emacs/helm/helm-3.2.ebuild31
-rw-r--r--app-emacs/helm/metadata.xml20
4 files changed, 54 insertions, 0 deletions
diff --git a/app-emacs/helm/Manifest b/app-emacs/helm/Manifest
new file mode 100644
index 000000000000..c4d109907e65
--- /dev/null
+++ b/app-emacs/helm/Manifest
@@ -0,0 +1 @@
+DIST helm-3.2.tar.gz 2285972 BLAKE2B b5385b805825d89ed87ba438ce830ce1e694cf842db590576b0ceaa2c110f5d0853b24211fdeebb77394c5ecca8460bcd52fe58240233ea10993504030328e9e SHA512 006e53f1984d38fa6305830179bc4ef04fa3007effa07685ddf479c1fbca547b6f8e99dd370f5653d57b2f8e519a54948a4730a0fdf9af8574cbfa27c09662d5
diff --git a/app-emacs/helm/files/50helm-gentoo.el b/app-emacs/helm/files/50helm-gentoo.el
new file mode 100644
index 000000000000..2eeea8036582
--- /dev/null
+++ b/app-emacs/helm/files/50helm-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/helm-autoloads" nil t)
diff --git a/app-emacs/helm/helm-3.2.ebuild b/app-emacs/helm/helm-3.2.ebuild
new file mode 100644
index 000000000000..f852381e5353
--- /dev/null
+++ b/app-emacs/helm/helm-3.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="Emacs incremental completion and selection narrowing framework"
+HOMEPAGE="https://emacs-helm.github.io/helm/"
+SRC_URI="https://github.com/emacs-helm/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-emacs/async
+ app-emacs/popup"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+ exeinto "${SITEETC}/${PN}"
+ doexe emacs-helm.sh
+}
diff --git a/app-emacs/helm/metadata.xml b/app-emacs/helm/metadata.xml
new file mode 100644
index 000000000000..a17d69b2f155
--- /dev/null
+++ b/app-emacs/helm/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+ Helm is an Emacs framework for incremental completions and narrowing
+ selections. It provides an easy-to-use API for developers wishing to
+ build their own Helm applications in Emacs, powerful search tools and
+ dozens of already built-in commands providing completion to almost
+ everything. It is a must-have for anyone using Emacs as a main work
+ environment. Helm has been widely adopted by many Emacs power-users.
+</longdescription>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">emacs-helm/helm</remote-id>
+</upstream>
+</pkgmetadata>