summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-05-02 02:36:10 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-05-02 02:39:03 +0200
commit37bc9abfa152d6cc79d8920513f2fd81758d0cac (patch)
treeee3d7865aac3b05fc90a4e39e25b5115634c386d /app-emacs
parentapp-emacs/org-mode: bump to 9.6.5 (diff)
downloadgentoo-37bc9abfa152d6cc79d8920513f2fd81758d0cac.tar.gz
gentoo-37bc9abfa152d6cc79d8920513f2fd81758d0cac.tar.bz2
gentoo-37bc9abfa152d6cc79d8920513f2fd81758d0cac.zip
app-emacs/osm: bump to 0.12
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/osm/Manifest1
-rw-r--r--app-emacs/osm/osm-0.12.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-emacs/osm/Manifest b/app-emacs/osm/Manifest
index 60064a268295..35ec692ae5c3 100644
--- a/app-emacs/osm/Manifest
+++ b/app-emacs/osm/Manifest
@@ -1,2 +1,3 @@
DIST osm-0.10.tar.gz 31628 BLAKE2B 6cb3d4fcee65b93787507fcdc15afce521e4d65c2fcea9f729e5292bfc57ec065604c8439bc5d0d744969c36fcba14204257a93546d1c67a9d3d8a816e26e9e7 SHA512 03ad03b9b64244c53c2b9a7329b9d741f33102e41684488385bdc60e5398b9cba7d3950cb0937b4bdecb93017cb2c1b5f99324195349b88ae7eed66431149ba6
DIST osm-0.11.tar.gz 31935 BLAKE2B d4cb18a9ab17d0d982db94a1dcfb37bdf3676b2b6bf367f249ccc2475783ce4f7eda8bb01beff8ac59e4a963e7800402f3fe9a99832f9072396d679a4fa0bd56 SHA512 02faba5200897b78b1e8d616d3f21a607645e401b80e13d016be8317cc92dcd7458d6b968066f088d9ee202d477e183c9d93bf1475710f6a6c249608cb68b0d6
+DIST osm-0.12.tar.gz 32029 BLAKE2B 42a8f70acb01ac0b326ac0e345528f2181e5ab45a92bfcc796d2d8cab5b587e4b071c5d1235cc92f4362be3849cd454015de096314b2de0ebd02bdc631588e03 SHA512 ad21fe39c096250f8e5249ae67c399ccb976a48576ced9e9ed4accbd7cbeed4a30e3c347ca5b4ba2f8e2b7db5a161b3145b01121860b9ee3880d06241bec3edc
diff --git a/app-emacs/osm/osm-0.12.ebuild b/app-emacs/osm/osm-0.12.ebuild
new file mode 100644
index 000000000000..e10c84ef5e7f
--- /dev/null
+++ b/app-emacs/osm/osm-0.12.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="OpenStreetMap tile-based viewer for GNU Emacs"
+HOMEPAGE="https://github.com/minad/osm/"
+SRC_URI="https://github.com/minad/osm/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ >=app-editors/emacs-${NEED_EMACS}:*[jpeg,json,libxml2,png,svg]
+ >=app-emacs/compat-29.1.4.0
+"
+RDEPEND="
+ ${BDEPEND}
+ net-misc/curl[ssl]
+"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}