summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-12-06 01:54:53 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-12-06 03:19:20 +0100
commit8b1213fdc1f82abfc187313296f001b2fe4d78a5 (patch)
treef453cc4d1c54e783acd90965326becd47d297172 /app-emacs
parentapp-emulation/vendor-reset: drop 0.1.0 (diff)
downloadgentoo-8b1213fdc1f82abfc187313296f001b2fe4d78a5.tar.gz
gentoo-8b1213fdc1f82abfc187313296f001b2fe4d78a5.tar.bz2
gentoo-8b1213fdc1f82abfc187313296f001b2fe4d78a5.zip
app-emacs/buttercup: bump to 1.29
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/buttercup/Manifest1
-rw-r--r--app-emacs/buttercup/buttercup-1.29.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/buttercup/Manifest b/app-emacs/buttercup/Manifest
index 78935aed1039..7b86169400ca 100644
--- a/app-emacs/buttercup/Manifest
+++ b/app-emacs/buttercup/Manifest
@@ -1,3 +1,4 @@
DIST buttercup-1.26.tar.gz 87554 BLAKE2B ee5d37360b6c9daa8b790f7ea6ae5bf7ff4266b1fcbe913877aefd4ede2e7d6561e48eae533c17c906e19b498d9d127692597ee728bd1fa791430f5f6ab508c8 SHA512 fb491e1db33ffaeca52529630c538040487a7bdf7766faab2c6a1bc39d1060c5bbbb7a259006b741abbec9b9a6911f8390b2513e0a4dddf856b79274ed24307c
DIST buttercup-1.27.tar.gz 87761 BLAKE2B d372e3285bb80a0005e79142dc95d219a2219959974039083df502ceeec10281aaeaa57f97c8bf45ec1d31b530934faf03b24d2a40e94f09f1cce4a986ae602b SHA512 537c1cc1fc560000537f3894f0917738ab344a4b117eac927b290bc8b5d01b6ad1df1caad63e1f339edc8f4bcaa9cdf483995e2730661481b53dd5e693a33f34
DIST buttercup-1.28.tar.gz 87689 BLAKE2B 510741e02c5973c80f3b6d9374d179b132ead8aefddee530f9a5f2cd5e6603bcb925060e40d614ec6804bc6aa918e6dea568d47ad3295c427066ab4c4953b37e SHA512 b83f1a9e14bce6e6e63047788bfa4e34b8d958c6422a52829c8752e6af7622764021c1574f812160472de123f0cdc68edb6daa0703d3b2633e84fe7df6ddeacc
+DIST buttercup-1.29.tar.gz 87693 BLAKE2B f42b98303a058dc3435b00dc5b50eb7217cfd70b48f982cb8823401b4d603ba2292a3235077d1263ddeba69284f6d7a37e407869dd3d4357102f1e765b14bf4e SHA512 3d400dfe5020fffefa5e8b32b9d5b8191a4882d790a9c5d48267cb021ffd0d6e9256116dca0d6118e920a2a0a2902bba7a2f73504c165cad71a4fc7f9867542f
diff --git a/app-emacs/buttercup/buttercup-1.29.ebuild b/app-emacs/buttercup/buttercup-1.29.ebuild
new file mode 100644
index 000000000000..cfebece4d7cc
--- /dev/null
+++ b/app-emacs/buttercup/buttercup-1.29.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="24.3"
+
+inherit elisp
+
+DESCRIPTION="Behaviour-driven Elisp testing"
+HOMEPAGE="https://github.com/jorgenschaefer/emacs-buttercup"
+SRC_URI="https://github.com/jorgenschaefer/emacs-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/emacs-${P}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DOCS=( docs/{running,writing}-tests.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -l buttercup \
+ -f buttercup-run-discover || die "tests failed"
+}
+
+src_install() {
+ elisp_src_install
+ dobin bin/${PN}
+}