summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-10 20:44:51 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-10 22:02:02 +0200
commitc4a8f328436d2554f40643fdf8f4519fd0774353 (patch)
tree29d7c549fd9e602bdd7264954b1f83ec02dbabb1 /app-emacs
parentapp-emacs/amx: new package; add version 3.4 (diff)
downloadgentoo-c4a8f328436d2554f40643fdf8f4519fd0774353.tar.gz
gentoo-c4a8f328436d2554f40643fdf8f4519fd0774353.tar.bz2
gentoo-c4a8f328436d2554f40643fdf8f4519fd0774353.zip
app-emacs/all-the-icons: new package; add version 5.0.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/all-the-icons/Manifest1
-rw-r--r--app-emacs/all-the-icons/all-the-icons-5.0.0.ebuild43
-rw-r--r--app-emacs/all-the-icons/files/50all-the-icons-gentoo.el1
-rw-r--r--app-emacs/all-the-icons/metadata.xml13
4 files changed, 58 insertions, 0 deletions
diff --git a/app-emacs/all-the-icons/Manifest b/app-emacs/all-the-icons/Manifest
new file mode 100644
index 000000000000..15ad6fcfb521
--- /dev/null
+++ b/app-emacs/all-the-icons/Manifest
@@ -0,0 +1 @@
+DIST all-the-icons-5.0.0.tar.gz 805496 BLAKE2B c5d81d2ff534bb7ab0000c21fb32107f307d96b1bf09b9227be5900e8160b133cfdc7ea4d4b31a982abb55e29bcf35626af91e3bd9ecbfba00b9b5ed85496a7f SHA512 865db191900dbeb207220df8d91220179dfbbb37e983e9e306ba0a4be576055002beb7335de20327736e8be678056699e8385aa37de766fadc11f4688f99471e
diff --git a/app-emacs/all-the-icons/all-the-icons-5.0.0.ebuild b/app-emacs/all-the-icons/all-the-icons-5.0.0.ebuild
new file mode 100644
index 000000000000..cb1873d52bb6
--- /dev/null
+++ b/app-emacs/all-the-icons/all-the-icons-5.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.3
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="Various icon fonts propertized for Emacs"
+HOMEPAGE="https://github.com/domtronn/all-the-icons.el/"
+SRC_URI="https://github.com/domtronn/${PN}.el/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}.el-${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/f )"
+
+DOC_CONTENTS="You may need to install the required fonts by executing
+ the \"all-the-icons-install-fonts\" function."
+DOCS=( README.md logo.png )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-compile data/*.el
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS} \
+ -L . -L data -L test -l test/all-the-icons-test.el \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}
+
+src_install() {
+ elisp_src_install
+ elisp-install ${PN}/data data/*.el{,c}
+}
diff --git a/app-emacs/all-the-icons/files/50all-the-icons-gentoo.el b/app-emacs/all-the-icons/files/50all-the-icons-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/all-the-icons/files/50all-the-icons-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/all-the-icons/metadata.xml b/app-emacs/all-the-icons/metadata.xml
new file mode 100644
index 000000000000..05396e7cc8b6
--- /dev/null
+++ b/app-emacs/all-the-icons/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/domtronn/all-the-icons.el/issues/</bugs-to>
+ <remote-id type="github">domtronn/all-the-icons.el</remote-id>
+ </upstream>
+</pkgmetadata>