summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-29 11:47:23 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-29 11:47:34 +0200
commitc4d71c55f2dac9faaf80fef5be268082d3f6a5f2 (patch)
treeb7a772af0dd1520e8e2bd3c96799921b04447c00 /app-emacs
parentx11-wm/xpra: Version bump to 4.3.3 (diff)
downloadgentoo-c4d71c55f2dac9faaf80fef5be268082d3f6a5f2.tar.gz
gentoo-c4d71c55f2dac9faaf80fef5be268082d3f6a5f2.tar.bz2
gentoo-c4d71c55f2dac9faaf80fef5be268082d3f6a5f2.zip
app-emacs/sly: new package; add version 1.0.43
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/sly/Manifest1
-rw-r--r--app-emacs/sly/files/50sly-gentoo.el3
-rw-r--r--app-emacs/sly/metadata.xml36
-rw-r--r--app-emacs/sly/sly-1.0.43.ebuild67
4 files changed, 107 insertions, 0 deletions
diff --git a/app-emacs/sly/Manifest b/app-emacs/sly/Manifest
new file mode 100644
index 000000000000..b29638518d9b
--- /dev/null
+++ b/app-emacs/sly/Manifest
@@ -0,0 +1 @@
+DIST sly-1.0.43.tar.gz 1835404 BLAKE2B ab6868f3ee29d3d98d80984de4dd1ba39076279b86d86de49ce4e95323c419cbd6a16da81d9cbdff8bc8d12fb2d868096ecffd681b276e35a192feb723f99baf SHA512 e2785a34cabc3537efb06cd2ce9da05aef02ce7077ef73e2d82ace4e3534c00d9269969319294207759e11e2682111ca4d150f1d3d8e02b8f682752394640447
diff --git a/app-emacs/sly/files/50sly-gentoo.el b/app-emacs/sly/files/50sly-gentoo.el
new file mode 100644
index 000000000000..c69b93515bcb
--- /dev/null
+++ b/app-emacs/sly/files/50sly-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(add-to-list 'load-path "@SITELISP@/contrib")
+(require 'sly-autoloads)
diff --git a/app-emacs/sly/metadata.xml b/app-emacs/sly/metadata.xml
new file mode 100644
index 000000000000..1f4866127cad
--- /dev/null
+++ b/app-emacs/sly/metadata.xml
@@ -0,0 +1,36 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ SLY is Sylvester the Cat's Common Lisp IDE for Emacs.
+ SLY is a fork of SLIME. All SLIME's familar features (debugger, inspector,
+ xref, etc...) are still available, with improved overall UX. SLY's
+ highlights are:
+ A full-featured REPL based on Emacs's comint.el. Everything can be copied
+ to the REPL;
+ Stickers, or live code annotations that record values as code traverses
+ them.
+ Flex-style completion out-of-the-box, using Emacs's completion API.
+ Company, Helm, and other supported natively, no plugin required;
+ An interactive Trace Dialog;
+ Cleanly ASDF-loaded by default, including contribs, enabled out-of-the-box;
+ Multiple inspectors and multiple REPLs;
+ "Presentations" replaced by interactive backreferences which highlight the
+ object and remain stable throughout the REPL session;
+ Support for NAMED-READTABLES, macrostep.el and quicklisp.
+ A portable, annotation-based stepper in early but functional prototype
+ stage.
+ </longdescription>
+ <use>
+ <flag name="xref">Install xref.lisp cross-referencing tool</flag>
+ </use>
+ <upstream>
+ <bugs-to>https://github.com/joaotavora/sly/issues/</bugs-to>
+ <remote-id type="github">joaotavora/sly</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/sly/sly-1.0.43.ebuild b/app-emacs/sly/sly-1.0.43.ebuild
new file mode 100644
index 000000000000..ebec756037f0
--- /dev/null
+++ b/app-emacs/sly/sly-1.0.43.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Sylvester the Cat's Common Lisp IDE for GNU Emacs"
+HOMEPAGE="https://github.com/joaotavora/sly/"
+SRC_URI="https://github.com/joaotavora/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain GPL-2+ GPL-3+ LLGPL-2.1 ZLIB xref? ( xref.lisp )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc xref"
+
+RDEPEND="
+ dev-lisp/asdf
+ dev-lisp/sbcl
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-apps/texinfo
+ doc? ( virtual/texi2dvi )
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+
+ # Remove failing tests (sly-fontifying-fu-tests is a part of "check-fancy")
+ rm test/sly-fontifying-fu-tests.el || die
+
+ # Remove xref.lisp (which is non-free) unless USE flag is set
+ use xref || rm slynk/xref.lisp || die
+}
+
+src_compile() {
+ emake EMACS="${EMACS}" compile compile-contrib
+
+ emake -C doc ${PN}.info
+
+ if use doc ; then
+ VARTEXFONTS="${T}"/fonts emake -C doc all
+ fi
+}
+
+src_test() {
+ # NOTICE: "check-core" has some failing tests under root/portage user
+ emake check-fancy
+}
+
+src_install() {
+ elisp-install ${PN} *el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ elisp-install ${PN}/contrib/ contrib/*
+ elisp-install ${PN}/lib/ lib/* lib/.nosearch
+ elisp-install ${PN}/slynk/ slynk/*
+ elisp-install ${PN}/slynk/backend/ slynk/backend/*
+
+ doinfo doc/${PN}.info
+ dodoc CONTRIBUTING.md NEWS.md PROBLEMS.md README.md
+
+ use doc && dodoc doc/*.pdf
+}