summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-11-02 19:14:52 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-11-08 13:26:44 +0100
commitd109462977ea81362681fb176ad26091095858ed (patch)
tree659f74a94a5004696ed12d60f8f93bbb52c8fae0 /app-emacs
parentsys-devel/llvm-common: Remove 10* (diff)
downloadgentoo-d109462977ea81362681fb176ad26091095858ed.tar.gz
gentoo-d109462977ea81362681fb176ad26091095858ed.tar.bz2
gentoo-d109462977ea81362681fb176ad26091095858ed.zip
app-emacs/pariemacs: EAPI 8
Closes: https://bugs.gentoo.org/704752 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/22798 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/pariemacs/pariemacs-3.14-r1.ebuild (renamed from app-emacs/pariemacs/pariemacs-3.14.ebuild)31
1 files changed, 16 insertions, 15 deletions
diff --git a/app-emacs/pariemacs/pariemacs-3.14.ebuild b/app-emacs/pariemacs/pariemacs-3.14-r1.ebuild
index aa608c9b7eaa..e94c56789e55 100644
--- a/app-emacs/pariemacs/pariemacs-3.14.ebuild
+++ b/app-emacs/pariemacs/pariemacs-3.14-r1.ebuild
@@ -1,38 +1,39 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit elisp
DESCRIPTION="sci-mathematics/pari emacs mode"
HOMEPAGE="http://iml.univ-mrs.fr/~ramare/ServeurPerso/GP-PARI/"
+SRC_URI="http://iml.univ-mrs.fr/~ramare/ServeurPerso/GP-PARI/latest-pari-distrib/${P}.tar.gz"
+S="${WORKDIR}"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-SRC_URI="http://iml.univ-mrs.fr/~ramare/ServeurPerso/GP-PARI/latest-pari-distrib/${P}.tar.gz"
RDEPEND="sci-mathematics/pari"
DEPEND="${RDEPEND}"
-S="${WORKDIR}"
SITEFILE="64${PN}-gentoo.el"
DOCS="README CHANGES"
+PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
src_prepare() {
- eapply "${FILESDIR}"/${P}-makefile.patch
- eapply_user
- if [ -f /usr/share/doc/pari-*/pari.cfg ]; then
- cp /usr/share/doc/pari-*/pari.cfg .
- elif [ -f /usr/share/doc/pari-*/pari.cfg.bz2 ]; then
- cp /usr/share/doc/pari-*/pari.cfg.bz2 .
- bunzip2 pari.cfg.bz2
- else die "pari.cfg not found"
+ default
+ if [ -f /usr/share/pari/pari.cfg ]; then
+ cp /usr/share/pari/pari.cfg . || die
+ elif [ -f /usr/share/pari/pari.cfg.bz2 ]; then
+ cp /usr/share/pari/pari.cfg.bz2 . || die
+ bunzip2 pari.cfg.bz2 || die
+ else
+ die "pari.cfg not found"
fi
}
src_compile() {
- make pari-conf.el
- make elc
+ emake pari-conf.el
+ emake elc
}