summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Privoznik <michal.privoznik@gmail.com>2022-11-01 13:37:03 +0100
committerMatthias Maier <tamiko@gentoo.org>2022-11-11 09:14:21 -0600
commitd4e165df74a6faab2b965c63462f8c7a379622a1 (patch)
treefe2009c3a33358491251fcf378d6506a739f4fb2 /app-emacs
parentapp-emulation/libvirt: Add 8.9.0 (diff)
downloadgentoo-d4e165df74a6faab2b965c63462f8c7a379622a1.tar.gz
gentoo-d4e165df74a6faab2b965c63462f8c7a379622a1.tar.bz2
gentoo-d4e165df74a6faab2b965c63462f8c7a379622a1.zip
app-emacs/nxml-libvirt-schemas: add 8.9.0
Signed-off-by: Michal Privoznik <michal.privoznik@gmail.com> Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/nxml-libvirt-schemas/Manifest1
-rw-r--r--app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-8.9.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-emacs/nxml-libvirt-schemas/Manifest b/app-emacs/nxml-libvirt-schemas/Manifest
index f0b6d9751ef4..439b3805c810 100644
--- a/app-emacs/nxml-libvirt-schemas/Manifest
+++ b/app-emacs/nxml-libvirt-schemas/Manifest
@@ -1 +1,2 @@
DIST libvirt-8.8.0.tar.xz 8941928 BLAKE2B f3b8cb4fe30a156884a03e5c873f3fcef0c8d13315c79b865f387ea053635ae2435a3b4d6e81c988cfcd087d55223450e7b874e24e4503479d152b417c398250 SHA512 868e49b369afe200c5af6e2cd0606de2eeebfa92523b5ad3c653203c8838d304bd0cdc5acfb3c4d4c33c0a87ab8e769b84cc62e3f06e055936c43573a23d7190
+DIST libvirt-8.9.0.tar.xz 8946352 BLAKE2B 537b6badb6171110e99561613fb1318144991107139401296248afb747ae6f9cfafcd17b2292b8d8dcc9188ff4206035ea814efa6c129bae50c0518f61be9b81 SHA512 10426d45d55bb18e8e5d4327d698fbc6efd83c5f515ac40a0fcd72048a77936fe0b422ac14bce9966a65379d262df294c314f854a97861a223a0cbc6a8fd2382
diff --git a/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-8.9.0.ebuild b/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-8.9.0.ebuild
new file mode 100644
index 000000000000..1c0188f9655a
--- /dev/null
+++ b/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-8.9.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Packages which get releases together:
+# app-emacs/nxml-libvirt-schemas
+# dev-python/libvirt-python
+# dev-perl/Sys-Virt
+# app-emulation/libvirt
+# Please bump them together!
+
+inherit elisp
+
+MY_P="libvirt-${PV}"
+DESCRIPTION="Extension for nxml-mode with libvirt schemas"
+HOMEPAGE="https://www.libvirt.org/"
+SRC_URI="https://libvirt.org/sources/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P%-rc*}/src/conf/schemas"
+
+# This is the license of the package, but the schema files are
+# provided without license, maybe it's bad.
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Yes this requires Java, but I'd rather not repackage this, if you
+# know something better in C, I'll be glad to use that.
+BDEPEND="app-text/trang"
+
+SITEFILE="60${PN}-gentoo.el"
+
+src_compile() {
+ emake -f "${FILESDIR}"/Makefile-trang
+}
+
+src_install() {
+ insinto "${SITEETC}/${PN}"
+ doins "${FILESDIR}"/schemas.xml *.rnc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}