summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-23 22:08:10 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-23 23:06:53 +0100
commite34584b2495310983c4ce0c96e9c7aa3309fd6ba (patch)
tree016b7951f59d5b86a8f4ddba241812f489fc616c /app-emacs
parentapp-emacs/corfu: bump to 1.2 (diff)
downloadgentoo-e34584b2495310983c4ce0c96e9c7aa3309fd6ba.tar.gz
gentoo-e34584b2495310983c4ce0c96e9c7aa3309fd6ba.tar.bz2
gentoo-e34584b2495310983c4ce0c96e9c7aa3309fd6ba.zip
app-emacs/doom-modeline: bump to 4.1.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/doom-modeline/Manifest1
-rw-r--r--app-emacs/doom-modeline/doom-modeline-4.1.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/doom-modeline/Manifest b/app-emacs/doom-modeline/Manifest
index 532c90e063ea..d540649021ba 100644
--- a/app-emacs/doom-modeline/Manifest
+++ b/app-emacs/doom-modeline/Manifest
@@ -1,2 +1,3 @@
DIST doom-modeline-3.4.0.tar.gz 62357 BLAKE2B d3af3875b25f9ef8d2b75e1acd4ed9c7f8e3d5ba306731f019ae076d14339c97b9f7f59bbb0806e5443c39d855aa0af9c2f9509ca93b11a9a275aa341e4d431b SHA512 1ed7c061e43fdb1e5a9fbe1cc5f87021a90796057206c64ff4f590089e0b5bd835d27f95129c92e1deb50012dc033608b071fadd294df4f102d67cb2872b8b86
DIST doom-modeline-4.0.1.tar.gz 62968 BLAKE2B 5401917532acc9c69923107d557758ee576799252d86a0b6bb02fda0ca2278ce4f7074a166e1a56a6c2d21144142ebd625a0d1414798d74f31e4d8f8eb965bd4 SHA512 e38f58148b6ce2311a43300e45bf32b246250902d9e29bf6ce5da8977af60ff0fe40b3a6b3bb720b11a5c7d1cc5a3e0634f4f4b79abfae03e56a7ee8a5bfd73e
+DIST doom-modeline-4.1.0.tar.gz 64224 BLAKE2B cac0d28912e70d56c8cb839fe12c279db553d761bd3d75be9eb65c288f7a235a49fed1f9dd2bdad747778c1173d394b35a97b2b43c6e27420ba4b625f522830c SHA512 83f3cc5e2a39c01a3019282ac4245c644b4caa96bb0b8fcbe645e8a63dd0b5d2add36eab8468129b332d259212c7f011cb6481d34cdfb53faa334c3083b5ee3c
diff --git a/app-emacs/doom-modeline/doom-modeline-4.1.0.ebuild b/app-emacs/doom-modeline/doom-modeline-4.1.0.ebuild
new file mode 100644
index 000000000000..e35cedd72dc5
--- /dev/null
+++ b/app-emacs/doom-modeline/doom-modeline-4.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Fancy and fast mode-line for Emacs inspired by minimalism design"
+HOMEPAGE="https://seagle0128.github.io/doom-modeline/
+ https://github.com/seagle0128/doom-modeline/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/seagle0128/${PN}.git"
+else
+ SRC_URI="https://github.com/seagle0128/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ app-emacs/compat
+ app-emacs/nerd-icons
+ app-emacs/shrink-path
+"
+BDEPEND="${RDEPEND}"
+
+elisp-enable-tests ert test
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}