summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-04 06:43:04 +0000
committerSam James <sam@gentoo.org>2021-03-04 06:43:30 +0000
commite8c14f917f1a7c6443be60bc55c735f96883e495 (patch)
treecd7fdca13eb59c8e57454c7e96176eae28a85b23 /app-emacs
parentapp-editors/retext: fix MisplacedEclassVar (diff)
downloadgentoo-e8c14f917f1a7c6443be60bc55c735f96883e495.tar.gz
gentoo-e8c14f917f1a7c6443be60bc55c735f96883e495.tar.bz2
gentoo-e8c14f917f1a7c6443be60bc55c735f96883e495.zip
app-emacs/pymacs: fix MisplacedEclassVar
We should set variables before inheriting eclasses in case they take action at source-time. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/pymacs/pymacs-0.26-r2.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/app-emacs/pymacs/pymacs-0.26-r2.ebuild b/app-emacs/pymacs/pymacs-0.26-r2.ebuild
index 490525cd0be6..d4393702f094 100644
--- a/app-emacs/pymacs/pymacs-0.26-r2.ebuild
+++ b/app-emacs/pymacs/pymacs-0.26-r2.ebuild
@@ -2,8 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_IN_SOURCE_BUILD=1
+DISTUTILS_USE_SETUPTOOLS="no"
inherit elisp distutils-r1
DESCRIPTION="A tool that allows both-side communication beetween Python and Emacs Lisp"
@@ -21,8 +23,7 @@ BDEPEND="doc? (
)"
S="${WORKDIR}/${P^}"
-DISTUTILS_IN_SOURCE_BUILD=1
-DISTUTILS_USE_SETUPTOOLS="no"
+
SITEFILE="50${PN}-gentoo.el"
# called by distutils-r1 for every python implementation