summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-04-08 22:32:59 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-04-09 00:00:10 +0200
commiteb02509a8d5806f0472ab0619ad8d037366e61b1 (patch)
tree74d986116c809fc460676d9467dfd04f2e335a0f /app-emacs
parentdev-util/reuse: add 3.0.2 (diff)
downloadgentoo-eb02509a8d5806f0472ab0619ad8d037366e61b1.tar.gz
gentoo-eb02509a8d5806f0472ab0619ad8d037366e61b1.tar.bz2
gentoo-eb02509a8d5806f0472ab0619ad8d037366e61b1.zip
app-emacs/treemacs: bump to 3.1_p20240229
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/treemacs/Manifest1
-rw-r--r--app-emacs/treemacs/treemacs-3.1_p20240229.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/app-emacs/treemacs/Manifest b/app-emacs/treemacs/Manifest
index 58c616d904f5..67c445fbf04e 100644
--- a/app-emacs/treemacs/Manifest
+++ b/app-emacs/treemacs/Manifest
@@ -1 +1,2 @@
DIST treemacs-3.1.tar.gz 4562915 BLAKE2B b728c6ea795fe1159c2342b593cc4e6b3d06a1ba58dca876e5472e394b77a3a9930740aa9ecb65973f551322018920f08b0b49e897d5677b7a0f1da42cfad2d3 SHA512 e891cfa68916ecc250ab0446a4eb0149deea17a7f366870ce757e73f175bc823dae87080a584ea315d502c50559d030055f2f399cbd92d40af8c2dca5308604c
+DIST treemacs-3.1_p20240229.tar.gz 4701534 BLAKE2B 3b3e5dbef181efee4739f96ee0ef0de68f344fa68b890b22c0ec808ec1c3b7afc6cd353124e2c6e5e70c931492ac0c9a3e4cee5c66b5c25ba4cc72b296ade6f0 SHA512 40631b77a71b13b0aed2f703386d98b8444c7630f952ba8d49160ba99abc13b8636169fee8cd23bbc372a7d7ae83b863e11ac891deb8cc5d2e961ccfee9f60da
diff --git a/app-emacs/treemacs/treemacs-3.1_p20240229.ebuild b/app-emacs/treemacs/treemacs-3.1_p20240229.ebuild
new file mode 100644
index 000000000000..b7337b3db652
--- /dev/null
+++ b/app-emacs/treemacs/treemacs-3.1_p20240229.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+DISTUTILS_USE_PEP517=no
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 elisp
+
+DESCRIPTION="Tree style project file explorer"
+HOMEPAGE="https://github.com/Alexander-Miller/treemacs/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/Alexander-Miller/${PN}.git"
+else
+ COMMIT_SHA=8c6df39f01a4d47fda2cc943645fa067f771b748
+ SRC_URI="https://github.com/Alexander-Miller/${PN}/archive/${COMMIT_SHA}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT_SHA}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-editors/emacs-${NEED_EMACS}[svg]
+ app-emacs/ace-window
+ app-emacs/cfrs
+ app-emacs/dash
+ app-emacs/ht
+ app-emacs/hydra
+ app-emacs/pfuture
+ app-emacs/s
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+BYTECOMPFLAGS="-L . -L src/elisp"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.9.5-tests.patch"
+ "${FILESDIR}/${PN}-async-scripts.patch"
+ "${FILESDIR}/${PN}-icons-icon-directory.patch"
+)
+
+DOCS=( Changelog.org Extensions.org README.org screenshots )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests buttercup test
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ sed -e "s|@SITEETC@|${SITEETC}/${PN}|g" \
+ -i "src/elisp/${PN}-icons.el" \
+ -i "src/elisp/${PN}-async.el" \
+ || die
+}
+
+python_compile() {
+ python_optimize "${S}/src/scripts"
+}
+
+src_compile() {
+ distutils-r1_src_compile
+
+ elisp-compile src/elisp/*.el
+}
+
+src_install() {
+ elisp-install "${PN}" src/elisp/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ insinto "${SITEETC}/${PN}"
+ doins -r icons
+ doins -r src/scripts
+}