summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-05-11 17:05:18 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-05-11 17:34:30 +0200
commitf343f6a4c71f59542cc9f89e9ff0b85f2fc68f0d (patch)
tree23a3e6f50553fa56322d94beefb0f9310402d817 /app-emacs
parentapp-emacs/ts: new package; add 0.3 (diff)
downloadgentoo-f343f6a4c71f59542cc9f89e9ff0b85f2fc68f0d.tar.gz
gentoo-f343f6a4c71f59542cc9f89e9ff0b85f2fc68f0d.tar.bz2
gentoo-f343f6a4c71f59542cc9f89e9ff0b85f2fc68f0d.zip
app-emacs/plz: new package; add 0.5.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/plz/Manifest1
-rw-r--r--app-emacs/plz/files/50plz-gentoo.el1
-rw-r--r--app-emacs/plz/metadata.xml20
-rw-r--r--app-emacs/plz/plz-0.5.4.ebuild38
4 files changed, 60 insertions, 0 deletions
diff --git a/app-emacs/plz/Manifest b/app-emacs/plz/Manifest
new file mode 100644
index 000000000000..11c45c67187d
--- /dev/null
+++ b/app-emacs/plz/Manifest
@@ -0,0 +1 @@
+DIST plz-0.5.4.tar.gz 101382 BLAKE2B cba7089ed3f6c6d616d6d8b506e9779c1fdc56b8c048010cb2e61f03d83669aa3475314936c9fc4b02d473484268a303495605e785840644bc3b9b92f50be090 SHA512 3a64a49efcf32191099abcd5dd5955b02ce3afa98ec3ecd79d4bfaadf52bc4a5602fda3aca4482e77e465e5d071400ae8200cf900e4f0ed931e93e1458303fa1
diff --git a/app-emacs/plz/files/50plz-gentoo.el b/app-emacs/plz/files/50plz-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/plz/files/50plz-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/plz/metadata.xml b/app-emacs/plz/metadata.xml
new file mode 100644
index 000000000000..312ec018bd3c
--- /dev/null
+++ b/app-emacs/plz/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ plz is an HTTP library for Emacs. It uses curl as a backend, which avoids
+ some of the issues with using Emacs's built-in url library. It supports
+ both synchronous and asynchronous requests. Its API is intended to be
+ simple, natural, and expressive. Its code is intended to be simple and
+ well-organized. Every feature is tested against httpbin.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/alphapapa/plz.el/issues/</bugs-to>
+ <remote-id type="github">alphapapa/plz.el</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/plz/plz-0.5.4.ebuild b/app-emacs/plz/plz-0.5.4.ebuild
new file mode 100644
index 000000000000..fc3776f2a6fa
--- /dev/null
+++ b/app-emacs/plz/plz-0.5.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="HTTP library with curl backend for GNU Emacs"
+HOMEPAGE="https://github.com/alphapapa/plz.el/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/alphapapa/plz.el.git"
+else
+ SRC_URI="https://github.com/alphapapa/plz.el/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/plz.el-${PV}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+# Tests require network access.
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="net-misc/curl"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert tests -l tests/test-plz.el
+
+src_install() {
+ elisp_src_install
+
+ doinfo plz.info
+}