summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-05-26 07:59:50 +0200
committerHans de Graaff <graaff@gentoo.org>2021-05-27 08:06:03 +0200
commitf96e0a809cbe035d4bf17474229691ea2b7cb1ec (patch)
tree0f93ae051bc2fee1fc0e9324000ae14bbfb6409a /app-emacs
parentapp-emacs/with-editor: add 3.0.4 (diff)
downloadgentoo-f96e0a809cbe035d4bf17474229691ea2b7cb1ec.tar.gz
gentoo-f96e0a809cbe035d4bf17474229691ea2b7cb1ec.tar.bz2
gentoo-f96e0a809cbe035d4bf17474229691ea2b7cb1ec.zip
app-emacs/transient: initial import of 0.3.4
New dependency for app-emacs/magit Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/transient/Manifest1
-rw-r--r--app-emacs/transient/files/50transient-gentoo.el1
-rw-r--r--app-emacs/transient/metadata.xml35
-rw-r--r--app-emacs/transient/transient-0.3.4.ebuild29
4 files changed, 66 insertions, 0 deletions
diff --git a/app-emacs/transient/Manifest b/app-emacs/transient/Manifest
new file mode 100644
index 000000000000..d4b2135ea56b
--- /dev/null
+++ b/app-emacs/transient/Manifest
@@ -0,0 +1 @@
+DIST transient-0.3.4.tar.gz 100193 BLAKE2B 0dd91cf1af22cfd6c3b6fefaa1b84ba3a241e269aef5165befa9408171f8b5477b04e2886e690cfd8d20af31e83fe669e05f0bf40c3391aab353d33a59345689 SHA512 feb24bf9045c9212a45cbc0a99805bdad6f4f5871279d44c64a883ad5d33a40128189525ee546d6cff14bf2d60d3c1e684cf8894fefc01860e363073eafea220
diff --git a/app-emacs/transient/files/50transient-gentoo.el b/app-emacs/transient/files/50transient-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/transient/files/50transient-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/transient/metadata.xml b/app-emacs/transient/metadata.xml
new file mode 100644
index 000000000000..f01b2556a6ac
--- /dev/null
+++ b/app-emacs/transient/metadata.xml
@@ -0,0 +1,35 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+ Taking inspiration from prefix keys and prefix arguments, Transient
+ implements a similar abstraction involving a prefix command, infix
+ arguments and suffix commands. We could call this abstraction a
+ "transient command", but because it always involves at least two
+ commands (a prefix and a suffix) we prefer to call it just a
+ "transient".
+
+ When the user calls a transient prefix command, then a transient
+ (temporary) keymap is activated, which binds the transient's infix
+ and suffix commands, and functions that control the transient state
+ are added to `pre-command-hook' and `post-command-hook'. The
+ available suffix and infix commands and their state are shown in
+ the echo area until the transient is exited by invoking a suffix
+ command.
+
+ Calling an infix command causes its value to be changed, possibly
+ by reading a new value in the minibuffer.
+
+ Calling a suffix command usually causes the transient to be exited
+ but suffix commands can also be configured to not exit the
+ transient state.
+</longdescription>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">magit/transient</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/transient/transient-0.3.4.ebuild b/app-emacs/transient/transient-0.3.4.ebuild
new file mode 100644
index 000000000000..5f2eb4af6a92
--- /dev/null
+++ b/app-emacs/transient/transient-0.3.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="Use the Emacsclient as the \$EDITOR of child processes"
+HOMEPAGE="https://magit.vc/manual/transient"
+SRC_URI="https://github.com/magit/transient/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="docs/*.texi"
+DOCS="README.md docs/transient.org"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} sys-apps/texinfo"
+
+src_prepare() {
+ mv lisp/*.el . || die
+
+ default
+}