summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-05-15 12:24:10 -0400
committerCraig Andrews <candrews@gentoo.org>2018-05-17 13:30:32 -0400
commitab5303b4ea459e7a829d36fe3198c7e350953e8d (patch)
tree6defb5d824bcd325c0c9683ba8042d56bc0424ec /app-emulation/containerd/containerd-1.0.3_p20180223-r1.ebuild
parentdev-python/protobuf-python: arm stable wrt bug #654428 (diff)
downloadgentoo-ab5303b4ea459e7a829d36fe3198c7e350953e8d.tar.gz
gentoo-ab5303b4ea459e7a829d36fe3198c7e350953e8d.tar.bz2
gentoo-ab5303b4ea459e7a829d36fe3198c7e350953e8d.zip
app-emulation/containerd: Fix "overflows _Ctype_ulonglong" error with GCC 8
Closes: https://bugs.gentoo.org/655804 Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'app-emulation/containerd/containerd-1.0.3_p20180223-r1.ebuild')
-rw-r--r--app-emulation/containerd/containerd-1.0.3_p20180223-r1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-emulation/containerd/containerd-1.0.3_p20180223-r1.ebuild b/app-emulation/containerd/containerd-1.0.3_p20180223-r1.ebuild
new file mode 100644
index 000000000000..a25ff621428d
--- /dev/null
+++ b/app-emulation/containerd/containerd-1.0.3_p20180223-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/containerd/${PN}"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ MY_PV="${PV/_rc/-rc.}"
+ EGIT_COMMIT="v${MY_PV}"
+ CONTAINERD_COMMIT="4ac4fd0b6a268fe6f38b2b2e32e40daa7e424fac"
+ SRC_URI="https://${EGO_PN}/archive/${CONTAINERD_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.tools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+btrfs hardened"
+
+DEPEND="btrfs? ( sys-fs/btrfs-progs )"
+RDEPEND="|| ( >=app-emulation/docker-runc-1.0.0_rc4
+ >=app-emulation/runc-1.0.0_rc4 )
+ sys-libs/libseccomp"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/"${P}-remove-c-constant-redefinitions.patch"
+)
+
+src_prepare() {
+ default
+ if [[ ${PV} != *9999* ]]; then
+ sed -i -e "s/git describe --match.*$/echo ${PV})/"\
+ -e "s/git rev-parse HEAD.*$/echo $CONTAINERD_COMMIT)/"\
+ -e "s/-s -w//" \
+ Makefile || die
+ fi
+}
+
+src_compile() {
+ local options=( $(usex btrfs "" "no_btrfs") )
+ export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
+ LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') emake BUILDTAGS="${options[@]}"
+}
+
+src_install() {
+ dobin bin/containerd{-shim,-stress,} bin/ctr
+}