summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-02-07 13:01:18 +0100
committerManuel Rüger <mrueg@gentoo.org>2019-02-07 13:01:18 +0100
commitb8f6aff9acb4cbc32d79486ecdff09e4adf5d5f4 (patch)
tree0574cd6b1d05326b4fab1c3211203e203f31f732 /app-emulation/containerd/containerd-1.1.1.ebuild
parentapp-emulation/containerd: Version bump to 1.2.3 (diff)
downloadgentoo-b8f6aff9acb4cbc32d79486ecdff09e4adf5d5f4.tar.gz
gentoo-b8f6aff9acb4cbc32d79486ecdff09e4adf5d5f4.tar.bz2
gentoo-b8f6aff9acb4cbc32d79486ecdff09e4adf5d5f4.zip
app-emulation/containerd: Remove old
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'app-emulation/containerd/containerd-1.1.1.ebuild')
-rw-r--r--app-emulation/containerd/containerd-1.1.1.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/app-emulation/containerd/containerd-1.1.1.ebuild b/app-emulation/containerd/containerd-1.1.1.ebuild
deleted file mode 100644
index 0dc6845f4ea2..000000000000
--- a/app-emulation/containerd/containerd-1.1.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-EGO_PN="github.com/containerd/${PN}"
-
-inherit toolchain-funcs
-
-if [[ ${PV} == *9999 ]]; then
- inherit golang-vcs
-else
- MY_PV="${PV/_rc/-rc.}"
- EGIT_COMMIT="v${MY_PV}"
- CONTAINERD_COMMIT="d64c661f1d51c48782c9cec8fda7604785f93587"
- SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
- inherit golang-vcs-snapshot
-fi
-
-DESCRIPTION="A daemon to control runC"
-HOMEPAGE="https://containerd.tools"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="+btrfs hardened"
-
-DEPEND="btrfs? ( sys-fs/btrfs-progs )"
-RDEPEND="|| ( >=app-emulation/docker-runc-1.0.0_rc4
- >=app-emulation/runc-1.0.0_rc4 )
- sys-libs/libseccomp"
-
-S=${WORKDIR}/${P}/src/${EGO_PN}
-
-RESTRICT="test"
-
-src_prepare() {
- default
- if [[ ${PV} != *9999* ]]; then
- sed -i -e "s/git describe --match.*$/echo ${PV})/"\
- -e "s/git rev-parse HEAD.*$/echo $CONTAINERD_COMMIT)/"\
- -e "s/-s -w//" \
- Makefile || die
- fi
-}
-
-src_compile() {
- local options=( $(usex btrfs "" "no_btrfs") )
- export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
- LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') emake BUILDTAGS="${options[@]}"
-}
-
-src_install() {
- dobin bin/containerd{-shim,-stress,} bin/ctr
-}