summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-09-26 13:20:26 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-09-26 13:20:26 +0200
commit4f8214f5250c024dd67c5f62f3acee771943088c (patch)
treec4108cc4ddadb4ca68be8567bedbb4486cc0ea3f /app-emulation/containerd/containerd-1.1.4.ebuild
parentapp-admin/helm: Version bump to 2.11.0 (diff)
downloadgentoo-4f8214f5250c024dd67c5f62f3acee771943088c.tar.gz
gentoo-4f8214f5250c024dd67c5f62f3acee771943088c.tar.bz2
gentoo-4f8214f5250c024dd67c5f62f3acee771943088c.zip
app-emulation/containerd: Version bump to 1.1.4
Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'app-emulation/containerd/containerd-1.1.4.ebuild')
-rw-r--r--app-emulation/containerd/containerd-1.1.4.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-emulation/containerd/containerd-1.1.4.ebuild b/app-emulation/containerd/containerd-1.1.4.ebuild
new file mode 100644
index 000000000000..0d07ff805fcc
--- /dev/null
+++ b/app-emulation/containerd/containerd-1.1.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/containerd/${PN}"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ MY_PV="${PV/_rc/-rc.}"
+ EGIT_COMMIT="v${MY_PV}"
+ CONTAINERD_COMMIT="9f2e07b1fc1342d1c48fe4d7bbb94cb6d1bf278b"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.tools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="apparmor +btrfs +cri hardened +seccomp"
+
+DEPEND="btrfs? ( sys-fs/btrfs-progs )
+ seccomp? ( sys-libs/libseccomp )"
+RDEPEND="|| ( >=app-emulation/docker-runc-1.0.0_rc4
+ >=app-emulation/runc-1.0.0_rc4 )
+ seccomp? ( sys-libs/libseccomp )"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ if [[ ${PV} != *9999* ]]; then
+ sed -i -e "s/git describe --match.*$/echo ${PV})/"\
+ -e "s/git rev-parse HEAD.*$/echo $CONTAINERD_COMMIT)/"\
+ -e "s/-s -w//" \
+ Makefile || die
+ fi
+}
+
+src_compile() {
+ local options=( $(usex btrfs "" "no_btrfs") $(usex cri "" "no_cri") $(usex seccomp "seccomp" "") $(usex apparmor "apparmor" "") )
+ export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
+ LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') BUILDTAGS="${options[@]}" emake
+}
+
+src_install() {
+ dobin bin/containerd{-shim,-stress,} bin/ctr
+}