summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-11-20 23:18:27 +0100
committerManuel Rüger <mrueg@gentoo.org>2019-11-20 23:18:27 +0100
commit51e7e08fa443bc88591389ae8726f11a3d58a503 (patch)
treeb6593e14412b35089b2e3fc832928f9a26cbe2d4 /app-emulation/containerd/containerd-1.3.1.ebuild
parentapp-admin/helm: Remove old (diff)
downloadgentoo-51e7e08fa443bc88591389ae8726f11a3d58a503.tar.gz
gentoo-51e7e08fa443bc88591389ae8726f11a3d58a503.tar.bz2
gentoo-51e7e08fa443bc88591389ae8726f11a3d58a503.zip
app-emulation/containerd: Version bump to 1.3.1
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'app-emulation/containerd/containerd-1.3.1.ebuild')
-rw-r--r--app-emulation/containerd/containerd-1.3.1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-emulation/containerd/containerd-1.3.1.ebuild b/app-emulation/containerd/containerd-1.3.1.ebuild
new file mode 100644
index 000000000000..69fbb115600c
--- /dev/null
+++ b/app-emulation/containerd/containerd-1.3.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/containerd/${PN}"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ MY_PV="${PV/_rc/-rc.}"
+ EGIT_COMMIT="v${MY_PV}"
+ CONTAINERD_COMMIT="c7a4f87"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.tools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="apparmor +btrfs +cri hardened +seccomp"
+
+DEPEND="btrfs? ( sys-fs/btrfs-progs )
+ seccomp? ( sys-libs/libseccomp )"
+RDEPEND=">=app-emulation/runc-1.0.0_rc9
+ seccomp? ( sys-libs/libseccomp )"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ if [[ ${PV} != *9999* ]]; then
+ sed -i -e "s/git describe --match.*$/echo ${PV})/"\
+ -e "s/git rev-parse HEAD.*$/echo $CONTAINERD_COMMIT)/"\
+ -e "s/-s -w//" \
+ Makefile || die
+ fi
+}
+
+src_compile() {
+ local options=( $(usex btrfs "" "no_btrfs") $(usex cri "" "no_cri") $(usex seccomp "seccomp" "") $(usex apparmor "apparmor" "") )
+ export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
+ LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') BUILDTAGS="${options[@]}" emake
+}
+
+src_install() {
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ keepdir /var/lib/containerd
+ dobin bin/*
+}