summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2016-04-17 11:35:21 -0500
committerKacper Kowalik <xarthisius@gentoo.org>2016-04-17 11:35:21 -0500
commitbf4e69347e7fce0c7a35fe4789e6c097c69d65f8 (patch)
tree3cb24124cfdab38020fb0b2f4a8ec889a0afa0ec /app-emulation/containerd/containerd-9999.ebuild
parentdev-util/ccache: version bump to 3.2.5 (diff)
downloadgentoo-bf4e69347e7fce0c7a35fe4789e6c097c69d65f8.tar.gz
gentoo-bf4e69347e7fce0c7a35fe4789e6c097c69d65f8.tar.bz2
gentoo-bf4e69347e7fce0c7a35fe4789e6c097c69d65f8.zip
app-emulation/containerd: initial import
Ebuild based on Tianon's work https://github.com/tianon/docker-overlay/tree/master/app-emulation/containerd Package-Manager: portage-2.2.27
Diffstat (limited to 'app-emulation/containerd/containerd-9999.ebuild')
-rw-r--r--app-emulation/containerd/containerd-9999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-emulation/containerd/containerd-9999.ebuild b/app-emulation/containerd/containerd-9999.ebuild
new file mode 100644
index 000000000000..c840962b287c
--- /dev/null
+++ b/app-emulation/containerd/containerd-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+EGO_PN="github.com/docker/${PN}"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ MY_PV="${PV/_/-}"
+ EGIT_COMMIT="v${MY_PV}"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.tools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+seccomp"
+
+DEPEND=""
+RDEPEND="app-emulation/runc
+ seccomp? ( sys-libs/libseccomp )"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+src_prepare() {
+ eapply_user
+}
+
+src_compile() {
+ local options=( $(usex seccomp "seccomp") )
+ export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
+ LDFLAGS= emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}"
+}
+
+src_install() {
+ dobin bin/containerd* bin/ctr
+}