summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-02-05 21:17:14 -0600
committerWilliam Hubbs <williamh@gentoo.org>2020-02-05 21:21:54 -0600
commit0cde6f45e86dc57c4812d1446ca1fee6698a67bb (patch)
treeb76af47693edd5f095d56998018943d93341182d /app-emulation/containerd
parentprofiles: x86: remove unmasking of ceph USE flag (diff)
downloadgentoo-0cde6f45e86dc57c4812d1446ca1fee6698a67bb.tar.gz
gentoo-0cde6f45e86dc57c4812d1446ca1fee6698a67bb.tar.bz2
gentoo-0cde6f45e86dc57c4812d1446ca1fee6698a67bb.zip
app-emulation/containerd: 1.2.12 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-emulation/containerd')
-rw-r--r--app-emulation/containerd/Manifest1
-rw-r--r--app-emulation/containerd/containerd-1.2.12.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-emulation/containerd/Manifest b/app-emulation/containerd/Manifest
index 9ecae2deadf3..e652b4a329ce 100644
--- a/app-emulation/containerd/Manifest
+++ b/app-emulation/containerd/Manifest
@@ -1,4 +1,5 @@
DIST containerd-1.2.10.tar.gz 4923354 BLAKE2B 6727fde9949ca96f351964df3c0c7481cb5274895aa3b31552258d57cc5958bd2d3006cfe4d87088d24ac53de1c391b6029b3f800363ee743f08e1937f0d0fec SHA512 14d4f1cad1a68414915c1e98b64dfb6f3f29a0e86e18570d6cc138f4db14b56499b978135954198fe9e2a1363383694eed530b301a9dc699d28c305d4dbf3cd8
+DIST containerd-1.2.12.tar.gz 4990623 BLAKE2B 640ff03f74e94dd3f919d3c26015cebae1f316c910442db881cd999c92991b7011131f05501648e9f08b6e34d38e2aa6ee1065ae31550de88ad79d9cafa5687e SHA512 bcb4f94aea984c804e34137cab6aad252c01dc75d5e33ade5d1e533e4266fd0af67d2bf8aa85f0e6eba4e43756e84f884f1dec4c9febd66f8a3e3bc8cd3ac775
DIST containerd-1.2.6.tar.gz 4874159 BLAKE2B 202e19cffbe2b5335558dc1db28ea28a05dcc9e9b3aad864e090d86f7590df9e67ae685c9fc6ab2b8abdd1762d001fa9b298b1d311c080449bc86087b6af8c36 SHA512 287b064cb3e57369e34f6debb434526d6bd4857e337e489c56e4ca484c66e161bbda911b4fc29cb49808a756f6ec7af5629e46d693644500e3bf2d9e45e87e73
DIST containerd-1.2.7.tar.gz 4877757 BLAKE2B 6cf98e370547d3ca5158f546e72e3ff5fdccc08c2e9f390988d080222195f95512dbf6f7dc042b7a966283a040000b7b8777b3fbeb4c5b861caae4f6209c59c5 SHA512 b96ca236d28933c1bf309fc7204af7d2c356e19af394d5c2274a178c8f15298faf6ca9bb8e7d04acb7c3c9c41035446643a8df0103017f7ed0320bfc37cb8ca9
DIST containerd-1.3.0.tar.gz 5697153 BLAKE2B c334cfd2aa11dd430c74bc9f3fe6f31d83faf752b9794da26021033bb6af492c48ed1665fc76ddfe5b858f04d45e9b77505f331e3c3da556af2d75e3cca3bb12 SHA512 cff9f0189b9fdc2b5492c92129af284aa8cd099e48de94cafd90aed191e2d20060c96008111b05fe081de0d4fc41d35f8cba5a3dc2d8cc0a5c37f695fd3cedc1
diff --git a/app-emulation/containerd/containerd-1.2.12.ebuild b/app-emulation/containerd/containerd-1.2.12.ebuild
new file mode 100644
index 000000000000..d2c5c94985c2
--- /dev/null
+++ b/app-emulation/containerd/containerd-1.2.12.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/containerd/${PN}"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ MY_PV="${PV/_rc/-rc.}"
+ EGIT_COMMIT="v${MY_PV}"
+ CONTAINERD_COMMIT=35bd7a5f69c13e1563af8a93431411cd9ecf5021
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.io/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="apparmor +btrfs +cri hardened +seccomp"
+
+DEPEND="btrfs? ( sys-fs/btrfs-progs )
+ seccomp? ( sys-libs/libseccomp )"
+RDEPEND=">=app-emulation/runc-1.0.0_rc8
+ seccomp? ( sys-libs/libseccomp )"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ if [[ ${PV} != *9999* ]]; then
+ sed -i -e "s/git describe --match.*$/echo ${PV})/"\
+ -e "s/git rev-parse HEAD.*$/echo $CONTAINERD_COMMIT)/"\
+ -e "s/-s -w//" \
+ Makefile || die
+ fi
+}
+
+src_compile() {
+ local options=( $(usex btrfs "" "no_btrfs") $(usex cri "" "no_cri") $(usex seccomp "seccomp" "") $(usex apparmor "apparmor" "") )
+ export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
+ LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') BUILDTAGS="${options[@]}" emake
+}
+
+src_install() {
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ keepdir /var/lib/containerd
+ dobin bin/*
+}