summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-07-26 14:24:13 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-07-26 14:24:41 -0700
commit682e0ab4966d624d99be7e9a954e476e950be926 (patch)
tree8bec64d63b4c7bbf3a7b78fdaac1db87e6f37beb /app-emulation/containerd
parentapp-emulation/containerd: drop 1.5.2 (diff)
downloadgentoo-682e0ab4966d624d99be7e9a954e476e950be926.tar.gz
gentoo-682e0ab4966d624d99be7e9a954e476e950be926.tar.bz2
gentoo-682e0ab4966d624d99be7e9a954e476e950be926.zip
app-emulation/containerd: drop 1.4.6
Bug: https://bugs.gentoo.org/802948 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-emulation/containerd')
-rw-r--r--app-emulation/containerd/Manifest1
-rw-r--r--app-emulation/containerd/containerd-1.4.6.ebuild84
2 files changed, 0 insertions, 85 deletions
diff --git a/app-emulation/containerd/Manifest b/app-emulation/containerd/Manifest
index 53d555771a67..090fef9f9e6c 100644
--- a/app-emulation/containerd/Manifest
+++ b/app-emulation/containerd/Manifest
@@ -1,3 +1,2 @@
-DIST containerd-1.4.6.tar.gz 6266709 BLAKE2B 3187ff003da7c1d6023ff9516c7aa510de49ad1188750b9cb782feae638ef1c4c74834f62344324eec8983feb6e881013b56ceb112e91ca0995878b08f20d69f SHA512 4693e67d17a21fe9413add39173981f484c461c7e228b05a8a886052bc445617116808db6321a134bcfdf853f382a6f228e979669588a375b434d1425853b143
DIST containerd-1.4.8.tar.gz 6400374 BLAKE2B def2d6e47d550d641888289943fee5c860a5523b1b4e347efafbf43a8dbf9d86bbcef0f4286efdf2591a42faf75aa2dc0acad11f2cfcdd99c7e3e89fcd13fa22 SHA512 3c4c52a7a1b3fb76f7837ef7260024e25df14e86ccaea351a0811dd9b7335eddc94019e3fb7e6acb4a41a3dee9c18387d0b44ea406c3534c64e8a4b3dee6a45b
DIST containerd-1.5.4.tar.gz 7675134 BLAKE2B b50061655b0b78a9f4c8bf7355213d02517c5a15e3ff2a623e59ffcde8e7f59ef39aafaf9790f7d977b285eac4d38338505920cdd032d975c50d42605e7157a5 SHA512 91d2fce2dc218070078f0e9e8141d091eca9f23c0b1ff244180260f214a46cdd66ba5c89472b40c0875cbd25580e19765bb030abf2ad749cfd4eea712dacadc1
diff --git a/app-emulation/containerd/containerd-1.4.6.ebuild b/app-emulation/containerd/containerd-1.4.6.ebuild
deleted file mode 100644
index 8e9b81b35d7d..000000000000
--- a/app-emulation/containerd/containerd-1.4.6.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CONTAINERD_COMMIT=d71fcd7d8303cbf684402823e425e9dd2e99285d
-EGO_PN="github.com/containerd/${PN}"
-inherit golang-vcs-snapshot toolchain-funcs
-
-DESCRIPTION="A daemon to control runC"
-HOMEPAGE="https://containerd.io/"
-SRC_URI="https://github.com/containerd/containerd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc64 ~x86"
-IUSE="apparmor btrfs device-mapper +cri hardened +seccomp selinux test"
-
-DEPEND="
- btrfs? ( sys-fs/btrfs-progs )
- seccomp? ( sys-libs/libseccomp )
-"
-
-# recommended version of runc is found in script/setup/runc-version
-RDEPEND="
- ${DEPEND}
- ~app-emulation/runc-1.0.0_rc95
-"
-
-BDEPEND="
- dev-go/go-md2man
- virtual/pkgconfig
- test? ( ${RDEPEND} )
-"
-
-# tests require root or docker
-# upstream does not recommend stripping binary
-RESTRICT+=" strip test"
-
-S="${WORKDIR}/${P}/src/${EGO_PN}"
-
-src_prepare() {
- default
- sed -i -e "s/git describe --match.*$/echo ${PV})/"\
- -e "s/git rev-parse HEAD.*$/echo ${CONTAINERD_COMMIT})/"\
- -e "s/-s -w//" \
- Makefile || die
-}
-
-src_compile() {
- local options=(
- $(usev apparmor)
- $(usex btrfs "" "no_btrfs")
- $(usex cri "" "no_cri")
- $(usex device-mapper "" "no_devmapper")
- $(usev seccomp)
- $(usev selinux)
- )
-
- myemakeargs=(
- BUILDTAGS="${options[*]}"
- LDFLAGS="$(usex hardened '-extldflags -fno-PIC' '')"
- )
-
- export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
- export GOFLAGS="-v -x -mod=vendor"
- # race condition in man target https://bugs.gentoo.org/765100
- emake "${myemakeargs[@]}" man -j1 #nowarn
- emake "${myemakeargs[@]}" all
-}
-
-src_install() {
- dobin bin/*
- doman man/*
- newinitd "${FILESDIR}"/${PN}.initd "${PN}"
- keepdir /var/lib/containerd
-
- # we already installed manpages, remove markdown source
- # before installing docs directory
- rm -r docs/man || die
-
- local DOCS=( README.md PLUGINS.md docs/. )
- einstalldocs
-}