summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-11-07 13:42:39 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-11-07 13:42:39 +0100
commit4cc5216765a12c45a3d45a2ec71b1265dcd72230 (patch)
tree88a7c3e2d846b7daa6711c0733be12a66ef472da /app-emulation/cri-tools
parentapp-emulation/cri-tools: Add 1.0.0_alpha1 for kubernetes-1.9.x (diff)
downloadgentoo-4cc5216765a12c45a3d45a2ec71b1265dcd72230.tar.gz
gentoo-4cc5216765a12c45a3d45a2ec71b1265dcd72230.tar.bz2
gentoo-4cc5216765a12c45a3d45a2ec71b1265dcd72230.zip
app-emulation/cri-tools: Version bump to 1.12.0
Signed-off-by: Manuel Rüger <mrueg@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-emulation/cri-tools')
-rw-r--r--app-emulation/cri-tools/Manifest1
-rw-r--r--app-emulation/cri-tools/cri-tools-1.12.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-emulation/cri-tools/Manifest b/app-emulation/cri-tools/Manifest
index 1336ec686235..84b90e1fd4c2 100644
--- a/app-emulation/cri-tools/Manifest
+++ b/app-emulation/cri-tools/Manifest
@@ -1,2 +1,3 @@
DIST cri-tools-1.0.0_alpha1.tar.gz 2727719 BLAKE2B 6c413aff111ce279e86f1036c3efd0c98901ed42bce482b3877cec58a55958a80305c013b6e515dbb84ff3d8def41156b81a0749ce606fd3806a7fae3fc445f0 SHA512 e0fe6171ac1b1649be667b2924a1b163810fe18c51fb9c3fe363b381feb889d18872f8077e267a147058481f799a35f6a0b5f8d285215e216ee771d7ea74f66a
DIST cri-tools-1.0.0_beta2.tar.gz 2417018 BLAKE2B 06dc5675c339fb26fce92c3ca05f855da754a452b25554ab84da0b6528b56c01005a625a06ead9a0f1e51e3fee96b54865990927fc312efa96167f8a5ebe94f1 SHA512 f0aadf8659ae1731945c8403d5a6d30bb9ed1e2ebf1a1045541087652a0d7a45b35fea5346cbec37903425634d7f65ccd852b56a7db93f6bbf9c91ae4899f107
+DIST cri-tools-1.12.0.tar.gz 2608498 BLAKE2B 242e689ec69081838afe36b86e3f802e4ff3bfd50461026a8637dd777b8996d9e153fbab103c98fc5ad8bd82c4da52413ab4698f95db8f1c0fa7e825e8dd80f7 SHA512 394269515ac80dd2b995b20220b03e03bad8bbfa25cea8979777ab75830a0523f0945553ba5d3f7a900eabe9ccf67ebf5789627b46640a2fc46193aff101ba20
diff --git a/app-emulation/cri-tools/cri-tools-1.12.0.ebuild b/app-emulation/cri-tools/cri-tools-1.12.0.ebuild
new file mode 100644
index 000000000000..a298fcbf5cbf
--- /dev/null
+++ b/app-emulation/cri-tools/cri-tools-1.12.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2018 Sony Interactive Entertainment Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/kubernetes-sigs/cri-tools"
+MY_PV="v${PV/_beta/-beta.}"
+ARCHIVE_URI="https://${EGO_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="CLI and validation tools for Kubelet Container Runtime (CRI)"
+HOMEPAGE="https://github.com/kubernetes-sigs/cri-tools"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+src_compile() {
+ GOPATH="${S}" go test -c -v -ldflags="-X ${EGO_PN}/pkg/version.Version=${MY_PV}" -o bin/critest ${EGO_PN}/cmd/critest || die
+ GOPATH="${S}" go build -v -ldflags="-X ${EGO_PN}/pkg/version.Version=${MY_PV}" -o bin/crictl ${EGO_PN}/cmd/crictl || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/{docs,{README,RELEASE,CHANGELOG,CONTRIBUTING}.md}
+}