summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-5.0.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-5.0.1.ebuild')
-rw-r--r--app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-5.0.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-5.0.1.ebuild b/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-5.0.1.ebuild
new file mode 100644
index 000000000000..cfa7703bca70
--- /dev/null
+++ b/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-5.0.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit unpacker
+
+DESCRIPTION="simplified/streamlined version of wine with commercial support"
+HOMEPAGE="http://www.codeweavers.com/products/cxoffice/"
+SRC_URI="install-crossover-pro-${PV}.sh"
+
+LICENSE="CROSSOVER"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="nas"
+RESTRICT="bindist fetch strip"
+
+RDEPEND="
+ dev-util/desktop-file-utils
+ sys-libs/glibc
+ x11-libs/libXrandr[abi_x86_32(-)]
+ x11-libs/libXi[abi_x86_32(-)]
+ x11-libs/libXmu[abi_x86_32(-)]
+ x11-libs/libXxf86dga[abi_x86_32(-)]
+ x11-libs/libXxf86vm[abi_x86_32(-)]
+ nas? ( media-libs/nas[abi_x86_32(-)] )
+"
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE}"
+ einfo "and place ${A} in ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack_makeself # needed due to .sh extension; #415013
+}
+
+src_install() {
+ dodir /opt/cxoffice
+ cp -r * "${D}"/opt/cxoffice || die "cp failed"
+ rm -r "${D}"/opt/cxoffice/setup.{sh,data}
+ insinto /opt/cxoffice/etc
+ doins support/templates/cxoffice.conf
+}
+
+pkg_postinst() {
+ elog "Run /opt/cxoffice/bin/cxsetup as normal user to create"
+ elog "bottles and install Windows applications."
+}