summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-02-01 13:10:37 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2022-02-01 13:10:37 -0600
commit005afeaaac3c8f5e389d7399166374398a1b843a (patch)
treeb87148b8d7a4a6c97027b78d91e3753e39d5f038 /app-emulation/diskimage-builder
parentapp-admin/ansible: 5.3.0 bump (diff)
downloadgentoo-005afeaaac3c8f5e389d7399166374398a1b843a.tar.gz
gentoo-005afeaaac3c8f5e389d7399166374398a1b843a.tar.bz2
gentoo-005afeaaac3c8f5e389d7399166374398a1b843a.zip
app-emulation/diskimage-builder: 3.17.0 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation/diskimage-builder')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-3.17.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index df10251c17e5..85878196af6a 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1 +1,2 @@
DIST diskimage-builder-3.16.0.tar.gz 499320 BLAKE2B 2cf520957c270696a6c4c7f59d6c875d30e7245c9fa24d556ef90eca4bab9e45eb95ecc422bc84ac202df0ba8afbaac412663892c8ab18bd4847e5d630ea4e43 SHA512 e592fd9200681314519b6e58b4b3ba9106d3834e83e708b3f32c125a8f597252f43abec05b37a9f6b30397874d53b56740e2374d6d13f69e737d460f191bdd98
+DIST diskimage-builder-3.17.0.tar.gz 500580 BLAKE2B f219e8e1a3224dd23871a3d4f4688c6e8b75ad681763227a0dde34b3f89b0f5a7af827c1717a161f310590090cc0852936edb6b9e7298bbc989b01e4af28662d SHA512 466039b6cf83636a2a245b5d36f7bf0e71e897edf092010219a40bcbe1804b0fe1f205eec2388cfbcd2e2adfdaf9256c53a01e3cf7ca48663e0296d4bf542a31
diff --git a/app-emulation/diskimage-builder/diskimage-builder-3.17.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-3.17.0.ebuild
new file mode 100644
index 000000000000..a2d3ad209af7
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-3.17.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder"
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"