summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-05-04 19:52:08 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-05-04 19:58:35 -0500
commit2068478eaf728a2c9cfdb556aefc065eeca0115f (patch)
treef9251c73b73e96d486f12b25386fee4dc1152db7 /app-emulation/diskimage-builder
parentsci-mathematics/octave: fix patch filename (diff)
downloadgentoo-2068478eaf728a2c9cfdb556aefc065eeca0115f.tar.gz
gentoo-2068478eaf728a2c9cfdb556aefc065eeca0115f.tar.bz2
gentoo-2068478eaf728a2c9cfdb556aefc065eeca0115f.zip
app-emulation/diskimage-builder: 3.21.0 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation/diskimage-builder')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-3.21.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index 821361759eb7..985b5e3744b1 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1 +1,2 @@
DIST diskimage-builder-3.20.3.tar.gz 505078 BLAKE2B 857745074049d648d50e36f8976f41ae74147feffd86e8aed517e23adce78945e15cae82a586c8e1acf25edb0ce43439c8a7865831d31bd4994f7b7f5f07da4a SHA512 4631f8d4a1a7389d9e3c2f4b3fec9371b2ed01224116e4a359140da136ba3409d0dc3d1ff320f64bced8431da097005a9d49da84668306e3b50bbcee2a94d4ab
+DIST diskimage-builder-3.21.0.tar.gz 506289 BLAKE2B 842f1f4f97b4527dc78ea1969f86ddf2549e2c5d565ea1656d722f86089b6d663c432e9bfe31596921df9e0ed3face9a760283c47cc613307f778fae5b826537 SHA512 016f74e7eb91a01a60c42765627d57e450c82b66c53eee0570468cac72b2f17ac4fc4be9faccef1591504282b7b6648957dc6a3b6eb3641ef41dc7cdd7fde538
diff --git a/app-emulation/diskimage-builder/diskimage-builder-3.21.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-3.21.0.ebuild
new file mode 100644
index 000000000000..a2d3ad209af7
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-3.21.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder"
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"