summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-05-10 18:14:05 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-05-10 18:14:17 -0500
commit31c2f1282c6e158b474e2169a11c10e8dafd7759 (patch)
tree7a98199350081cf4ef60b06c226a75fbb8002a52 /app-emulation/diskimage-builder
parentnet-ftp/proftpd: Drop ~mips (diff)
downloadgentoo-31c2f1282c6e158b474e2169a11c10e8dafd7759.tar.gz
gentoo-31c2f1282c6e158b474e2169a11c10e8dafd7759.tar.bz2
gentoo-31c2f1282c6e158b474e2169a11c10e8dafd7759.zip
app-emulation/diskimage-builder: 3.21.1 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation/diskimage-builder')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-3.21.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index 985b5e3744b1..6635e395ea27 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1,2 +1,3 @@
DIST diskimage-builder-3.20.3.tar.gz 505078 BLAKE2B 857745074049d648d50e36f8976f41ae74147feffd86e8aed517e23adce78945e15cae82a586c8e1acf25edb0ce43439c8a7865831d31bd4994f7b7f5f07da4a SHA512 4631f8d4a1a7389d9e3c2f4b3fec9371b2ed01224116e4a359140da136ba3409d0dc3d1ff320f64bced8431da097005a9d49da84668306e3b50bbcee2a94d4ab
DIST diskimage-builder-3.21.0.tar.gz 506289 BLAKE2B 842f1f4f97b4527dc78ea1969f86ddf2549e2c5d565ea1656d722f86089b6d663c432e9bfe31596921df9e0ed3face9a760283c47cc613307f778fae5b826537 SHA512 016f74e7eb91a01a60c42765627d57e450c82b66c53eee0570468cac72b2f17ac4fc4be9faccef1591504282b7b6648957dc6a3b6eb3641ef41dc7cdd7fde538
+DIST diskimage-builder-3.21.1.tar.gz 506309 BLAKE2B 5a5a08c90449742e9ba1664043cdeaed3c38f9efeb722f99fdb1fa98ea48a2a18bddd4bee189e983d8dcc4b43151c61d92320e703fead8f52eb81c49c2f225d3 SHA512 fb63dfcfb93ddbaa98b1231684892ecc1b28802e805902d613a41692f0b91a68b583efb45e6bb608c6333ac90e5de95e75b18f711cdca683014623287037a952
diff --git a/app-emulation/diskimage-builder/diskimage-builder-3.21.1.ebuild b/app-emulation/diskimage-builder/diskimage-builder-3.21.1.ebuild
new file mode 100644
index 000000000000..a2d3ad209af7
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-3.21.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder"
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"