summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-04-15 13:07:31 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-04-15 13:07:31 -0500
commit959ae90196a7d2d2506935effa5a22083e807db6 (patch)
tree30292ba44509415abab5eaa92ac18c5eee58cb4a /app-emulation/diskimage-builder
parentdev-java/netty: Keyword 4.1.35 ppc64, #838442 (diff)
downloadgentoo-959ae90196a7d2d2506935effa5a22083e807db6.tar.gz
gentoo-959ae90196a7d2d2506935effa5a22083e807db6.tar.bz2
gentoo-959ae90196a7d2d2506935effa5a22083e807db6.zip
app-emulation/diskimage-builder: 3.20.3 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation/diskimage-builder')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-3.20.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index be19800492cc..bad7fbc34149 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1 +1,2 @@
DIST diskimage-builder-3.19.1.tar.gz 504083 BLAKE2B 4ae8dca5601d4258757d33c4851c842a4188026bb6f5ee36a2313e2400d017d2536e4e58d7777cfcd9257a2bb881a6cc92f1ea79e168ff438cbd786829aa1d29 SHA512 c7ff8a30ccf052dbeaffd1af2cef23058fbe5fe653c4f36b365743b8495fc5b9727d888654809b48a58f6c4dc920126ab86c41400de8fd348097a7d0117b9216
+DIST diskimage-builder-3.20.3.tar.gz 505078 BLAKE2B 857745074049d648d50e36f8976f41ae74147feffd86e8aed517e23adce78945e15cae82a586c8e1acf25edb0ce43439c8a7865831d31bd4994f7b7f5f07da4a SHA512 4631f8d4a1a7389d9e3c2f4b3fec9371b2ed01224116e4a359140da136ba3409d0dc3d1ff320f64bced8431da097005a9d49da84668306e3b50bbcee2a94d4ab
diff --git a/app-emulation/diskimage-builder/diskimage-builder-3.20.3.ebuild b/app-emulation/diskimage-builder/diskimage-builder-3.20.3.ebuild
new file mode 100644
index 000000000000..a2d3ad209af7
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-3.20.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder"
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"