summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-08-02 21:17:24 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-08-02 21:17:49 -0500
commitb7f75d34afdf71fb8a08f0fc5ec2a565a44de9d7 (patch)
treea9ab28d575827b9b9c33c89cb90fb8cad5ab2a5f /app-emulation/diskimage-builder
parentapp-editors/nano: add 6.4 (diff)
downloadgentoo-b7f75d34afdf71fb8a08f0fc5ec2a565a44de9d7.tar.gz
gentoo-b7f75d34afdf71fb8a08f0fc5ec2a565a44de9d7.tar.bz2
gentoo-b7f75d34afdf71fb8a08f0fc5ec2a565a44de9d7.zip
app-emulation/diskimage-builder: 3.23.0 bump
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation/diskimage-builder')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-3.23.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index 9c89f56b5a6c..8549bd7c921b 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1 +1,2 @@
DIST diskimage-builder-3.22.0.tar.gz 507997 BLAKE2B 559203fb5e92ff6b32e3cda6e977c46ea247f47f0d41d72db5f4e6fa6957c599814fa65f24b3d0783fbf95fa72efb52db2bfa30f608b08955bc64bc8c4943d59 SHA512 1a2c4f6301eb90268cc4cc47e600e2de404336f871606beaebadb367ab8976cf6618da3a9ed594682f53b84e70c2b658d519732031c9b3423a906876ba3b03a4
+DIST diskimage-builder-3.23.0.tar.gz 509773 BLAKE2B 5896571442b5e359cbae10df3c504c2a3df48ace6ec52294afbad6c03baf300336d955b0180a174395cad118da42dbacfb395df9b32a85976982ff5194ec9e18 SHA512 080bca891890a02a7a0c6910668ccc966a8f2282f62a8b89cd01d5165b4cb52e4bd198b7a2ff431d86a75acae86e7490389f7053f197947c820925d540a3c934
diff --git a/app-emulation/diskimage-builder/diskimage-builder-3.23.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-3.23.0.ebuild
new file mode 100644
index 000000000000..bbd75fbe73fb
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-3.23.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder"
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"