summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-06-29 16:13:16 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-06-29 16:13:57 -0500
commitd9c39bb1f89d89a0be62678cad45d868899e6f4d (patch)
tree52a00192c23d7dd0eb669fc2748e7631eddeb9f7 /app-emulation/diskimage-builder
parentdev-libs/libzip: 1.9.2 version bump (diff)
downloadgentoo-d9c39bb1f89d89a0be62678cad45d868899e6f4d.tar.gz
gentoo-d9c39bb1f89d89a0be62678cad45d868899e6f4d.tar.bz2
gentoo-d9c39bb1f89d89a0be62678cad45d868899e6f4d.zip
app-emulation/diskimage-builder: 3.22.0 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation/diskimage-builder')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-3.22.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index e1a631f508dd..7fc035015fd7 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1 +1,2 @@
DIST diskimage-builder-3.21.1.tar.gz 506309 BLAKE2B 5a5a08c90449742e9ba1664043cdeaed3c38f9efeb722f99fdb1fa98ea48a2a18bddd4bee189e983d8dcc4b43151c61d92320e703fead8f52eb81c49c2f225d3 SHA512 fb63dfcfb93ddbaa98b1231684892ecc1b28802e805902d613a41692f0b91a68b583efb45e6bb608c6333ac90e5de95e75b18f711cdca683014623287037a952
+DIST diskimage-builder-3.22.0.tar.gz 507997 BLAKE2B 559203fb5e92ff6b32e3cda6e977c46ea247f47f0d41d72db5f4e6fa6957c599814fa65f24b3d0783fbf95fa72efb52db2bfa30f608b08955bc64bc8c4943d59 SHA512 1a2c4f6301eb90268cc4cc47e600e2de404336f871606beaebadb367ab8976cf6618da3a9ed594682f53b84e70c2b658d519732031c9b3423a906876ba3b03a4
diff --git a/app-emulation/diskimage-builder/diskimage-builder-3.22.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-3.22.0.ebuild
new file mode 100644
index 000000000000..bbd75fbe73fb
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-3.22.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder"
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"