summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-03-23 17:29:11 +0100
committerSebastian Pipping <sping@gentoo.org>2021-03-23 17:30:29 +0100
commit46512197631acbc50aad51bfaf6f496c58386f27 (patch)
tree2c122032c31406151215a17a8a9f9fc5d75f2ce8 /app-emulation/docker-compose
parentx11-misc/xaos: [QA] Inherit l10n.eclass for strip-linguas (diff)
downloadgentoo-46512197631acbc50aad51bfaf6f496c58386f27.tar.gz
gentoo-46512197631acbc50aad51bfaf6f496c58386f27.tar.bz2
gentoo-46512197631acbc50aad51bfaf6f496c58386f27.zip
app-emulation/docker-compose: 1.28.6
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.17, Repoman-3.0.2
Diffstat (limited to 'app-emulation/docker-compose')
-rw-r--r--app-emulation/docker-compose/Manifest1
-rw-r--r--app-emulation/docker-compose/docker-compose-1.28.6.ebuild73
-rw-r--r--app-emulation/docker-compose/files/docker-compose-1.28.6-setup-py.patch67
3 files changed, 141 insertions, 0 deletions
diff --git a/app-emulation/docker-compose/Manifest b/app-emulation/docker-compose/Manifest
index 7c5219f5250b..88cfc2fa0ea9 100644
--- a/app-emulation/docker-compose/Manifest
+++ b/app-emulation/docker-compose/Manifest
@@ -1,3 +1,4 @@
DIST docker-compose-1.27.4.tar.gz 309308 BLAKE2B 098af5e0308de4fe72f8f7d5c9cbdb285ec1cb6fbd492baef8a4223f93591321c585ebabd4c7e4a40d7a1bce3ab2d7ccf4cee1d0a15e7f59bb80eb4df5b6c8d6 SHA512 b41b7cf88b1380021a30f9becb7567d1e154ef875c42b37483673b5107f1a26dae6868b92c6a61f695001eb63759b25f3729e6783272eb784047717cafea3b80
DIST docker-compose-1.28.4.tar.gz 318110 BLAKE2B 97a39c52a2e9819fa4632a16080b9b3a029c5b81caa1bcb5143e78b9c6f3981aa462ef23c6c08fcafe80f8b786ce4962959dc84fd4fe2003ceee3dddcb85f438 SHA512 ba0b8a8a87e154c36b499b0fbb422847bcec421bdcbb6a7fc4a4d8169ae410f6bb71867fbff42b670b3d5ae61101527eeb71e68d57458906796e2d64adc0e367
DIST docker-compose-1.28.5.tar.gz 318236 BLAKE2B 32aca16fdebd00c5b211404e82b44b9486340bfa379d4739d164d5aa75d4f35b95d914065c05fef585ea7e412035e582d8058f2b942a4ce17a9b2bc25ff0cd31 SHA512 1f2cc87b82d18c023e8c2d9eb2e991393c96f7a3ab17fa6871d0969a28162b6832f98b42c76cadc641416629f74eb00763c89e044ae8cf02a062bd74b58371c9
+DIST docker-compose-1.28.6.tar.gz 319216 BLAKE2B 6f35f13fd35e08223fd17406b219fcd8c97fe9a2e96a3210607d23d54923496a9a51271f359b1537b73bc5e407d175822075835f44406fcfe028cc23d8eaf9f9 SHA512 0aef0066e58ee3e9ac6ddfef71cd29ae46ba52ed641b6da7ffc74b9e9a60b3974593173e84ac863475bb5d2a3896a0d453fda4decb69101c91abc04f33e50d45
diff --git a/app-emulation/docker-compose/docker-compose-1.28.6.ebuild b/app-emulation/docker-compose/docker-compose-1.28.6.ebuild
new file mode 100644
index 000000000000..d9f80948b759
--- /dev/null
+++ b/app-emulation/docker-compose/docker-compose-1.28.6.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2018-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit bash-completion-r1 distutils-r1
+
+MY_PV=${PV/_/-}
+DESCRIPTION="Multi-container orchestration for Docker"
+HOMEPAGE="https://github.com/docker/compose"
+SRC_URI="https://github.com/docker/compose/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/distro-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-4.4.4[${PYTHON_USEDEP}]
+ >=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dotenv-0.13.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ >=dev-python/PySocks-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-5[${PYTHON_USEDEP}]
+ >=dev-python/ddt-1.2.2[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/compose-${MY_PV}"
+
+PATCHES=(
+ # Bug #679968 -- https://bugs.gentoo.org/679968
+ # Bug #681002 -- https://bugs.gentoo.org/681002
+ "${FILESDIR}"/${PN}-1.28.6-setup-py.patch
+)
+
+DOCS=( CHANGELOG.md README.md )
+
+src_prepare() {
+ # Address QA issue "docker-compose.exe: missing alias (symlink) for completed command."
+ sed 's,^\(complete.*\) docker-compose\.exe\(.*\),\1\2,' -i contrib/completion/bash/docker-compose || die
+
+ default
+}
+
+python_test() {
+ distutils_install_for_testing
+ ${PYTHON} -m pytest tests/unit/ || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp contrib/completion/bash/docker-compose ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/*
+
+ distutils-r1_python_install_all
+}
diff --git a/app-emulation/docker-compose/files/docker-compose-1.28.6-setup-py.patch b/app-emulation/docker-compose/files/docker-compose-1.28.6-setup-py.patch
new file mode 100644
index 000000000000..63ecd7f9642a
--- /dev/null
+++ b/app-emulation/docker-compose/files/docker-compose-1.28.6-setup-py.patch
@@ -0,0 +1,67 @@
+From 0efc455303f08b6a41df021972dfa337c527b9cb Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Tue, 23 Mar 2021 17:25:23 +0100
+Subject: [PATCH] setup.py: Drop generic upper version boundaries
+
+---
+ setup.py | 34 +++++++++++++++++-----------------
+ 1 file changed, 17 insertions(+), 17 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 7669979..59df626 100644
+--- a/setup.py
++++ b/setup.py
+@@ -25,33 +25,33 @@ def find_version(*file_paths):
+
+
+ install_requires = [
+- 'docopt >= 0.6.1, < 1',
+- 'PyYAML >= 3.10, < 6',
+- 'requests >= 2.20.0, < 3',
+- 'texttable >= 0.9.0, < 2',
+- 'websocket-client >= 0.32.0, < 1',
+- 'distro >= 1.5.0, < 2',
+- 'docker[ssh] >= 4.4.4, < 5',
+- 'dockerpty >= 0.4.1, < 1',
+- 'jsonschema >= 2.5.1, < 4',
+- 'python-dotenv >= 0.13.0, < 1',
++ 'docopt >= 0.6.1',
++ 'PyYAML >= 3.10',
++ 'requests >= 2.20.0',
++ 'texttable >= 0.9.0',
++ 'websocket-client >= 0.32.0',
++ 'distro >= 1.5.0',
++ 'docker[ssh] >= 4.4.4',
++ 'dockerpty >= 0.4.1',
++ 'jsonschema >= 2.5.1',
++ 'python-dotenv >= 0.13.0',
+ ]
+
+
+ tests_require = [
+- 'ddt >= 1.2.2, < 2',
+- 'pytest < 6',
++ 'ddt >= 1.2.2',
++ 'pytest',
+ ]
+
+
+ if sys.version_info[:2] < (3, 4):
+- tests_require.append('mock >= 1.0.1, < 4')
++ tests_require.append('mock >= 1.0.1')
+
+ extras_require = {
+- ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5, < 4'],
+- ':python_version < "3.8"': ['cached-property >= 1.2.0, < 2'],
+- ':sys_platform == "win32"': ['colorama >= 0.4, < 1'],
+- 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'],
++ ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5'],
++ ':python_version < "3.8"': ['cached-property >= 1.2.0'],
++ ':sys_platform == "win32"': ['colorama >= 0.4'],
++ 'socks': ['PySocks >= 1.5.6, != 1.5.7'],
+ 'tests': tests_require,
+ }
+
+--
+2.30.2
+