summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-01-08 11:49:57 -0600
committerWilliam Hubbs <williamh@gentoo.org>2021-01-08 11:49:57 -0600
commitf566517d91b66d31319968b38d53f9288ac0d576 (patch)
tree48d07c7ed1a70256b00b2a42f718c5e57f04048d /app-emulation/docker-proxy/docker-proxy-0.8.0_p20201215.ebuild
parentlicenses: Drop unused AdobeFlash-11.x (diff)
downloadgentoo-f566517d91b66d31319968b38d53f9288ac0d576.tar.gz
gentoo-f566517d91b66d31319968b38d53f9288ac0d576.tar.bz2
gentoo-f566517d91b66d31319968b38d53f9288ac0d576.zip
app-emulation/docker-proxy: 0.8.0_p20201215 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-emulation/docker-proxy/docker-proxy-0.8.0_p20201215.ebuild')
-rw-r--r--app-emulation/docker-proxy/docker-proxy-0.8.0_p20201215.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-emulation/docker-proxy/docker-proxy-0.8.0_p20201215.ebuild b/app-emulation/docker-proxy/docker-proxy-0.8.0_p20201215.ebuild
new file mode 100644
index 000000000000..61b8e08632b5
--- /dev/null
+++ b/app-emulation/docker-proxy/docker-proxy-0.8.0_p20201215.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+EGO_PN="github.com/docker/libnetwork"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ EGIT_COMMIT=fa125a3512ee0f6187721c88582bf8c4378bd4d7
+ SRC_URI="https://github.com/docker/libnetwork/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="Docker container networking"
+HOMEPAGE="https://github.com/docker/libnetwork"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+# needs dockerd
+RESTRICT="strip test"
+
+src_compile() {
+ GOPATH="${WORKDIR}/${P}" go build -o "bin/docker-proxy" ./cmd/proxy || die
+}
+
+src_install() {
+ dodoc README.md CHANGELOG.md
+ dobin bin/docker-proxy
+}