summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-08-28 16:55:24 -0700
committerZac Medico <zmedico@gentoo.org>2016-08-28 16:59:24 -0700
commit31b24a6817f631fe3efc4c6bd814e0e3bc0ec127 (patch)
treee24fa568cbd7c0689a600e9bbd46996ae7df1bea /app-emulation/docker-registry
parentapp-emulation/docker-registry: add copytruncate to logrotate config (diff)
downloadgentoo-31b24a6817f631fe3efc4c6bd814e0e3bc0ec127.tar.gz
gentoo-31b24a6817f631fe3efc4c6bd814e0e3bc0ec127.tar.bz2
gentoo-31b24a6817f631fe3efc4c6bd814e0e3bc0ec127.zip
app-emulation/docker-registry: version bump to 2.5.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-emulation/docker-registry')
-rw-r--r--app-emulation/docker-registry/Manifest1
-rw-r--r--app-emulation/docker-registry/docker-registry-2.5.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-emulation/docker-registry/Manifest b/app-emulation/docker-registry/Manifest
index 9607b5c0abd3..cc89b0c40fd5 100644
--- a/app-emulation/docker-registry/Manifest
+++ b/app-emulation/docker-registry/Manifest
@@ -1 +1,2 @@
DIST docker-registry-2.4.0.tar.gz 1294478 SHA256 cfd0c6212a05c047fa6a5b9093493d2de0b438936f2d7318a902263a4a3d7b0f SHA512 668ba35adbe897f73e93e3ec8766123a70b4d2b0d57d4ec3e9f77f6d60d381184acc331b04ab0391f4c648da223dd2338a4065027e6c63aa86b1f1a039d7e300 WHIRLPOOL b07b0f79b97547c33fa2b64bcf85cc1e2bac3e17c38d6bda18a5ed7cfc500938ee29c26c15fbbc5110b22c2d28764674034cf325519261b01ada71deb6b541be
+DIST docker-registry-2.5.0.tar.gz 1619051 SHA256 9b1b09bf0f54a37247a4d4532ceb1a3bc2381ac13a63a9a5989f374614517c1c SHA512 2c9b45a8fbceff32538b357b9bb42d86e6d21b664cffcfb476ed06177608f35cd81f6bfdb342df3edfdea2705569fcf5cba94be6a885ecaf69f68ff8569de781 WHIRLPOOL 6bb9d01c690c636e4069535253182bed0ccc8973c1682283376975f6d105338bbf21ca28900c74e12ceaf12427f3b381b7fac97d25c637a0596e30019f22d3b3
diff --git a/app-emulation/docker-registry/docker-registry-2.5.0.ebuild b/app-emulation/docker-registry/docker-registry-2.5.0.ebuild
new file mode 100644
index 000000000000..c5b0e84f4f65
--- /dev/null
+++ b/app-emulation/docker-registry/docker-registry-2.5.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit golang-vcs-snapshot systemd user
+
+KEYWORDS="~amd64"
+EGO_PN="github.com/docker/distribution/..."
+EGIT_COMMIT="v${PV}"
+SRC_URI="https://${EGO_PN%/*}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="Docker Registry 2.0"
+HOMEPAGE="https://${EGO_PN%/*}"
+LICENSE="Apache-2.0"
+SLOT="0/${PVR}"
+IUSE=""
+DEPEND=">=dev-lang/go-1.5"
+SVCNAME=registry
+
+pkg_setup() {
+ enewgroup ${SVCNAME}
+ enewuser ${SVCNAME} -1 -1 /dev/null ${SVCNAME}
+}
+
+src_compile() {
+ GOPATH="${S}" GO15VENDOREXPERIMENT=1 \
+ go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}" || die
+}
+
+src_install() {
+ golang_install_pkgs
+ exeinto /usr/libexec/${PN}
+ doexe "${S}"/bin/*
+ insinto /etc/docker/registry
+ newins "${S}"/src/${EGO_PN%/*}/cmd/registry/config-example.yml config.yml.example
+ newinitd "${FILESDIR}/${SVCNAME}.initd" "${SVCNAME}"
+ newconfd "${FILESDIR}/${SVCNAME}.confd" "${SVCNAME}"
+ systemd_dounit "${FILESDIR}/${SVCNAME}.service"
+ keepdir /var/{lib,log}/${SVCNAME}
+ fowners ${SVCNAME}:${SVCNAME} /var/{lib,log}/${SVCNAME}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${SVCNAME}.logrotated" "${SVCNAME}"
+}
+
+golang_install_pkgs() {
+ insinto $(dirname "${EPREFIX}$(get_golibdir)/src/${EGO_PN%/*}")
+ rm -rf "${S}"/src/${EGO_PN%/*}/.git* \
+ "${S}"/{src,pkg/$(go env GOOS)_$(go env GOARCH)}/${EGO_PN%/*}/vendor
+ doins -r "${S}"/src/${EGO_PN%/*}
+ insinto $(dirname "${EPREFIX}$(get_golibdir)/pkg/$(go env GOOS)_$(go env GOARCH)/${EGO_PN%/*}")
+ doins -r "${S}"/pkg/$(go env GOOS)_$(go env GOARCH)/${EGO_PN%/*}{,.a}
+}