summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-05-10 16:26:45 -0700
committerZac Medico <zmedico@gentoo.org>2020-05-10 17:19:10 -0700
commitc55241caddfca89aa1d45eeb4d83a587e0c77363 (patch)
tree950ab2352aafcec04495c064a0e604f5ff2f8483 /app-emulation/docker-swarm
parentwww-servers/nginx-unit: Post-stabilisation cleanup (diff)
downloadgentoo-c55241caddfca89aa1d45eeb4d83a587e0c77363.tar.gz
gentoo-c55241caddfca89aa1d45eeb4d83a587e0c77363.tar.bz2
gentoo-c55241caddfca89aa1d45eeb4d83a587e0c77363.zip
app-emulation/docker-swarm: Bump to version 1.2.9
Closes: https://bugs.gentoo.org/722184 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-emulation/docker-swarm')
-rw-r--r--app-emulation/docker-swarm/Manifest1
-rw-r--r--app-emulation/docker-swarm/docker-swarm-1.2.9.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-emulation/docker-swarm/Manifest b/app-emulation/docker-swarm/Manifest
index 5c30c4fd9692..8a2580cb8df3 100644
--- a/app-emulation/docker-swarm/Manifest
+++ b/app-emulation/docker-swarm/Manifest
@@ -1,4 +1,5 @@
DIST docker-swarm-1.2.5.tar.gz 4619026 BLAKE2B cae94bcb1bbb1f495b18662ac62ad3295d22547b332d6b6c4e55c070650fc3a1c314ef1ef696787b3109c0c5dce3c48979adc85031c0d65834d3d8ff5bd417b3 SHA512 2684c1fbb8e01c062c62137c874825120d0f2da0ca13808c1558ef01680a6f4d77bbff3769d1f59d9bb8011066f202dbb89c23d25597283cc24245db70731992
+DIST docker-swarm-1.2.9.tar.gz 1532493 BLAKE2B 243a3cb6d2e9f719d81947429c6616e93cf1b08187685922ad5daf732e61db12bd626fa26f30174af7e779c8ba45ecce7d2cfb33835ef985bdd57657e30e2228 SHA512 cc0e0e27d0ed4845abd99d1554630cc8e2ab0645d40a76358a83b2ea6d1bc5287dbf5d1aefdd2eb4302aeef3894725e75cae3f5da2353b045492a4357631daa2
DIST gobrake-2.0.8.tar.gz 6392 BLAKE2B ec3eccd5a52442163108c9e8f83e2e7a19ed45438c91e541d75af5cd44f382899098cecc5130c5d36a62ca53f1dc2062a82ec9e04b17e2db835cecdfbaa3b565 SHA512 76d1dfc55ddcbfa0b719d9eb3a75a0c8bc9d2f0308fef391cc59efa7c6b7607860c61c1e77d609d3a2d2cad473da359d0f1df98775a6da791a70d81f98ce5e6c
DIST gogo-protobuf-0.3.tar.gz 2116795 BLAKE2B 6b90ad97648e75724c69bb9b8d3cfb17b919a1121813c09ec463df99c290c117b0e0b87f43b285eb5147a205f2f926c223cc4b4d58205a286af2afa87dbd7f5b SHA512 57e1b1715d4811800da8cf9f2c72d202deae622d89715d7eff2ff0c406a0ea3778c187443abb17b072ae6fe57382844807f103837032759dab5420c860b99fb8
DIST logrus-0.11.0.tar.gz 24165 BLAKE2B 5d71a4b78d5c46e71401a08d9b0228236f74e864d14206bd6450268a3a41d5f2ac7155c39f250b9906ec132fa63ace6e8888f0ec482ed4a0828696326bbba25e SHA512 ee0b813e277cef0533800a966e6e07884b8de64e75c200439979f00986d84f98cfc750f7d4cb2a2b57d6524941fbba0c6211ce37da50d9a8ca99274f81639620
diff --git a/app-emulation/docker-swarm/docker-swarm-1.2.9.ebuild b/app-emulation/docker-swarm/docker-swarm-1.2.9.ebuild
new file mode 100644
index 000000000000..5ca267108edf
--- /dev/null
+++ b/app-emulation/docker-swarm/docker-swarm-1.2.9.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit go-module
+
+KEYWORDS="~amd64"
+EGO_PN=github.com/docker/swarm
+EGIT_COMMIT="527a849cc6b8297690f478905083fc77951da2a7"
+MY_PN=classicswarm
+SRC_URI="https://github.com/docker/classicswarm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="Swarm Classic: a container clustering system"
+HOMEPAGE="https://docs.docker.com/swarm"
+LICENSE="Apache-2.0 CC-BY-SA-4.0 BSD BSD-2 ISC MIT MPL-2.0 WTFPL-2"
+SLOT="0"
+IUSE=""
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ # It would require internet access to run `go mod vendor`, so
+ # generate approximate go.mod and vendor/modules.txt from the
+ # content of vendor.conf. Use a dummy vendor_version that is
+ # good enough for go to recognize as a valid version.
+ rm -f go.mod vendor/modules.txt || die
+ local x vendor_version=v1.0.0
+ printf -- 'module %s\n' "${EGO_PN}" >> go.mod || die
+ printf -- 'go 1.14\n' >> go.mod || die
+ printf -- 'require (\n' >> go.mod || die
+ while read -r x; do
+ printf -- '\t%s %s\n' "${x}" "${vendor_version}" >> go.mod || die
+ printf -- '# %s %s\n' "${x}" "${vendor_version}" >> vendor/modules.txt || die
+ printf -- '## explicit\n' >> vendor/modules.txt || die
+ printf -- '%s\n' "${x}" >> vendor/modules.txt || die
+ done < <(grep -Eo "^[^#[:space:]]+" vendor.conf)
+ printf -- ')\n' >> go.mod || die
+ default
+}
+
+src_compile() {
+ GOBIN="${S}/bin" \
+ go install -v -work -x -mod=vendor -x \
+ -ldflags "-w -X github.com/docker/swarm/version.GITCOMMIT=${EGIT_COMMIT} \
+ -X github.com/docker/swarm/version.BUILDTIME=$(date -u +%FT%T%z)" \
+ ./... || die
+}
+
+src_install() {
+ dobin bin/swarm
+ dosym swarm /usr/bin/docker-swarm
+ dodoc CHANGELOG.md CONTRIBUTING.md logo.png README.md
+}