summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2016-07-27 17:12:00 -0500
committerWilliam Hubbs <williamh@gentoo.org>2016-07-27 17:12:27 -0500
commit719d916ff2d7314f1c77f536715f597d810963a9 (patch)
treedb22f241069c478af748290b117af48028fa12a8 /app-emulation/docker
parentapp-emulation/docker: 1.12.0_rc5: adjust CONFIG_MEMCG_KMEM check for #589552 (diff)
downloadgentoo-719d916ff2d7314f1c77f536715f597d810963a9.tar.gz
gentoo-719d916ff2d7314f1c77f536715f597d810963a9.tar.bz2
gentoo-719d916ff2d7314f1c77f536715f597d810963a9.zip
app-emulation/docker: sync live ebuild
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-emulation/docker')
-rw-r--r--app-emulation/docker/docker-9999.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/app-emulation/docker/docker-9999.ebuild b/app-emulation/docker/docker-9999.ebuild
index 9e2487c7e291..c4c359b91e35 100644
--- a/app-emulation/docker/docker-9999.ebuild
+++ b/app-emulation/docker/docker-9999.ebuild
@@ -80,7 +80,7 @@ CONFIG_CHECK="
~POSIX_MQUEUE
- ~MEMCG_KMEM ~MEMCG_SWAP ~MEMCG_SWAP_ENABLED
+ ~MEMCG_SWAP ~MEMCG_SWAP_ENABLED
~BLK_CGROUP ~IOSCHED_CFQ
~CGROUP_PERF
@@ -91,7 +91,6 @@ CONFIG_CHECK="
"
ERROR_KEYS="CONFIG_KEYS: is mandatory"
-ERROR_MEMCG_KMEM="CONFIG_MEMCG_KMEM: is optional"
ERROR_MEMCG_SWAP="CONFIG_MEMCG_SWAP: is required if you wish to limit swap usage of containers"
ERROR_RESOURCE_COUNTERS="CONFIG_RESOURCE_COUNTERS: is optional for container statistics gathering"
@@ -140,6 +139,13 @@ pkg_setup() {
"
fi
+ if kernel_is lt 4 5; then
+ CONFIG_CHECK+="
+ ~MEMCG_KMEM
+ "
+ ERROR_MEMCG_KMEM="CONFIG_MEMCG_KMEM: is optional"
+ fi
+
if use aufs; then
CONFIG_CHECK+="
~AUFS_FS