summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2019-10-17 00:46:08 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-10-30 22:19:48 +0000
commit47928b5c235ec1d105d64dde8d233df612beaa7c (patch)
treeacdb834465fc76e530f8e7a7ddb5da82bd03b5db /app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild
parentapp-shells/bash-completion: stable 2.9-r1 for hppa, bug #693738 (diff)
downloadgentoo-47928b5c235ec1d105d64dde8d233df612beaa7c.tar.gz
gentoo-47928b5c235ec1d105d64dde8d233df612beaa7c.tar.bz2
gentoo-47928b5c235ec1d105d64dde8d233df612beaa7c.zip
app-emulation/dosemu: Fix dependencies. Drop "sndfile" USE flag. Use EAPI="7".
Fixes: https://bugs.gentoo.org/697900 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild')
-rw-r--r--app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild51
1 files changed, 27 insertions, 24 deletions
diff --git a/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild b/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild
index 6eb911c30a14..d6de58d0a4b9 100644
--- a/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild
+++ b/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 2002-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI="7"
inherit autotools eutils flag-o-matic pax-utils toolchain-funcs
@@ -18,30 +18,32 @@ SRC_URI="mirror://sourceforge/dosemu/${P_FD}.tgz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-* amd64 x86"
-IUSE="X svga gpm debug alsa sndfile fluidsynth"
+IUSE="X alsa debug fluidsynth gpm svga"
-RDEPEND="X? ( x11-libs/libX11
- x11-libs/libXxf86vm
- x11-libs/libXau
- x11-libs/libXext
- x11-libs/libXdmcp
- x11-apps/xset
- x11-apps/xlsfonts
+BDEPEND="app-arch/unzip
+ X? (
x11-apps/bdftopcf
- >=x11-apps/mkfontscale-1.2.0 )
- svga? ( media-libs/svgalib )
- gpm? ( sys-libs/gpm )
+ >=x11-apps/mkfontscale-1.2.0
+ )"
+COMMON_DEPEND="media-libs/libsdl
+ >=sys-libs/slang-1.4
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXxf86vm
+ )
alsa? ( media-libs/alsa-lib )
- sndfile? ( media-libs/libsndfile )
- fluidsynth? ( media-sound/fluidsynth
- media-sound/fluid-soundfont )
- media-libs/libsdl
- >=sys-libs/slang-1.4"
-
-DEPEND="${RDEPEND}
- app-arch/unzip
- X? ( x11-base/xorg-proto )
- >=sys-devel/autoconf-2.57"
+ fluidsynth? (
+ media-sound/fluid-soundfont
+ media-sound/fluidsynth
+ )
+ gpm? ( sys-libs/gpm )
+ svga? ( media-libs/svgalib )"
+# sndfile? ( media-libs/libsndfile )
+DEPEND="${COMMON_DEPEND}
+ X? ( x11-base/xorg-proto )"
+RDEPEND="${COMMON_DEPEND}
+ X? ( x11-apps/xset )"
S="${WORKDIR}/${PN}-code-${COMMIT}"
@@ -79,13 +81,14 @@ src_configure() {
fi
fi
+ # sndfile support is unconditionally disabled in src/plugin/sndfile/snd_o_wav.c
econf $(use_with X x) \
$(use_with svga svgalib) \
$(use_enable debug) \
$(use_with gpm) \
$(use_with alsa) \
- $(use_with sndfile) \
$(use_with fluidsynth) \
+ --without-sndfile \
--with-fdtarball="${DISTDIR}"/${P_FD}.tgz \
--sysconfdir="${EPREFIX}"/etc/dosemu/ \
--with-docdir="${EPREFIX}"/usr/share/doc/${PF} \