summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-14 21:02:45 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-14 21:04:31 +0100
commit32407f8c9f5b1b9063435e0ceeca44d8a01439cf (patch)
treebab8260f7280072f039b4d3d0b8c43b6c933e65b /app-emulation/dynamips/dynamips-0.2.21.ebuild
parentapp-emulation/dynamips: Drop 0.2.18 (diff)
downloadgentoo-32407f8c9f5b1b9063435e0ceeca44d8a01439cf.tar.gz
gentoo-32407f8c9f5b1b9063435e0ceeca44d8a01439cf.tar.bz2
gentoo-32407f8c9f5b1b9063435e0ceeca44d8a01439cf.zip
app-emulation/dynamips: EAPI-7 bump
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-emulation/dynamips/dynamips-0.2.21.ebuild')
-rw-r--r--app-emulation/dynamips/dynamips-0.2.21.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/app-emulation/dynamips/dynamips-0.2.21.ebuild b/app-emulation/dynamips/dynamips-0.2.21.ebuild
index 21b04e6456e7..ad971daa108b 100644
--- a/app-emulation/dynamips/dynamips-0.2.21.ebuild
+++ b/app-emulation/dynamips/dynamips-0.2.21.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Cisco 7200/3600 Simulator"
HOMEPAGE="https://github.com/GNS3/dynamips"
@@ -16,7 +16,8 @@ KEYWORDS="~amd64 ~x86"
IUSE="ipv6"
BDEPEND="app-arch/unzip"
-RDEPEND="dev-libs/elfutils
+RDEPEND="
+ dev-libs/elfutils
net-libs/libpcap"
DEPEND="${RDEPEND}"
@@ -28,7 +29,7 @@ src_prepare() {
# comment out DYNAMIPS_FLAGS to respect CFLAGS
sed -e "s:^set ( DYNAMIPS_FLAGS:#&:" -i cmake/dependencies.cmake || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -36,5 +37,5 @@ src_configure() {
-DANY_COMPILER=1
-DENABLE_IPV6="$(usex ipv6)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}