summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-01-30 11:37:29 +0000
committerJames Le Cuirot <chewi@gentoo.org>2022-01-30 11:39:05 +0000
commit3c8c53f31727ec807fdb55226601d12aca76b5ee (patch)
tree08128cea7dc8030baa50dec468e816fa54a91483 /app-emulation/fs-uae-launcher
parentdev-python/prompt_toolkit: Keyword 3.0.26 for ~m68k (diff)
downloadgentoo-3c8c53f31727ec807fdb55226601d12aca76b5ee.tar.gz
gentoo-3c8c53f31727ec807fdb55226601d12aca76b5ee.tar.bz2
gentoo-3c8c53f31727ec807fdb55226601d12aca76b5ee.zip
app-emulation/fs-uae-launcher: Version bump to 3.1.68, Python 3.10
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'app-emulation/fs-uae-launcher')
-rw-r--r--app-emulation/fs-uae-launcher/Manifest1
-rw-r--r--app-emulation/fs-uae-launcher/fs-uae-launcher-3.1.68.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-emulation/fs-uae-launcher/Manifest b/app-emulation/fs-uae-launcher/Manifest
index 36daa6c7006b..240239908edd 100644
--- a/app-emulation/fs-uae-launcher/Manifest
+++ b/app-emulation/fs-uae-launcher/Manifest
@@ -1,2 +1,3 @@
DIST fs-uae-launcher-3.1.64.tar.xz 7719268 BLAKE2B 7753006e40e11d557f9cca90296b189638b832b8c2caebceb3fd5aa0393d3b1236ef2d47b176a900d26ab37012198afeb1549da92ba0570eb9b61df42c896550 SHA512 2f7c485f7707595a847130ebbaad3cf1fe9dc11149744bad2683b1b912a53830b687c0aa5ce97dc95a883182ef51020cc02fa434eac903752530f3780342090a
DIST fs-uae-launcher-3.1.66.tar.xz 7730328 BLAKE2B 68e141658d267c0bc574b216be5c99d10dff23d153e13cccc6a19c5abe618657ce3faf5c685e604ef55927a0dc713c0606f9e1f41e3bcd0015aeb232b9266713 SHA512 6232f43a0a41e67d912b277294079608808a7243512e7970900fab2be483ba82da99eaae547c41be059828c1f5d316e9b58ab8018651c9643b2b72cf7eb6f67e
+DIST fs-uae-launcher-3.1.68.tar.xz 7736036 BLAKE2B b2b14d568efa8c00b45497dea1bf73ac0b2522171269903f50ee68eff7e990f54c1b836af84a0b338caffd159fe3f638e6326db95f86482e190238e75894decd SHA512 a637117602c7276b60350ac3bb9c69eec4c18454efd4024e7b822da897eee0f9299f406e4126771f753b75f29d53591e9bbe3e4cbc016dda1ec063e73fe51f07
diff --git a/app-emulation/fs-uae-launcher/fs-uae-launcher-3.1.68.ebuild b/app-emulation/fs-uae-launcher/fs-uae-launcher-3.1.68.ebuild
new file mode 100644
index 000000000000..f0f95ef7d072
--- /dev/null
+++ b/app-emulation/fs-uae-launcher/fs-uae-launcher-3.1.68.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1 xdg
+
+DESCRIPTION="PyQt5-based launcher for FS-UAE"
+HOMEPAGE="https://fs-uae.net/"
+SRC_URI="https://fs-uae.net/files/FS-UAE-Launcher/Stable/${PV}/${P}.tar.xz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="lha"
+RESTRICT="test" # The test files are just boilerplate.
+
+RDEPEND="
+ app-emulation/fs-uae
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[${PYTHON_USEDEP},declarative,gui,network,opengl,widgets]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ lha? ( dev-python/python-lhafile[${PYTHON_USEDEP}] )
+ ')
+"
+
+BDEPEND="
+ sys-devel/gettext
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.0-ROMs.patch
+)
+
+python_compile_all() {
+ emake
+}
+
+python_install() {
+ local dir=${EPREFIX}/usr/share/${PN}
+ distutils-r1_python_install --install-lib="${dir}" --install-scripts="${dir}"
+}
+
+python_install_all() {
+ dosym ../share/${PN}/${PN} /usr/bin/${PN}
+ emake install-data DESTDIR="${D}" prefix="${EPREFIX}"/usr
+ mv "${ED}"/usr/share/doc/{${PN},${PF}} || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "Some important information:"
+ elog
+ ewarn " - Do not use QtCurve, it will crash PyQt5!"
+ elog
+ elog " - By default, FS-UAE creates its directories under Documents/FS-UAE."
+ elog " If your Documents directory is not configured according to the XDG"
+ elog " user diretory spec, ~/FS-UAE will be used as a fallback."
+ elog
+ elog " - You can override this by putting the path to the desired base"
+ elog " directory in a special config file. The config file will be read"
+ elog " from ~/.config/fs-uae/base-dir by both FS-UAE and FS-UAE Launcher"
+ elog " if it exists."
+ elog
+ elog " Alternatively, you can start FS-UAE and/or FS-UAE Launcher with"
+ elog " --base-dir=/path/to/desired/dir"
+}