summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-12-27 09:25:28 +0000
committerJames Le Cuirot <chewi@gentoo.org>2021-12-27 09:26:49 +0000
commitec9ebc98855ebdf3fc9672c3521689182dd8d641 (patch)
treef06b00f17886a75c700066e7ab0e9df6a7abc4aa /app-emulation/fs-uae-launcher
parentapp-emulation/fs-uae: Drop old 3.1.35 (diff)
downloadgentoo-ec9ebc98855ebdf3fc9672c3521689182dd8d641.tar.gz
gentoo-ec9ebc98855ebdf3fc9672c3521689182dd8d641.tar.bz2
gentoo-ec9ebc98855ebdf3fc9672c3521689182dd8d641.zip
app-emulation/fs-uae-launcher: Version bump to 3.1.66
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'app-emulation/fs-uae-launcher')
-rw-r--r--app-emulation/fs-uae-launcher/Manifest1
-rw-r--r--app-emulation/fs-uae-launcher/fs-uae-launcher-3.1.66.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-emulation/fs-uae-launcher/Manifest b/app-emulation/fs-uae-launcher/Manifest
index 7bfd8becebc9..ce18d05a042c 100644
--- a/app-emulation/fs-uae-launcher/Manifest
+++ b/app-emulation/fs-uae-launcher/Manifest
@@ -1,2 +1,3 @@
DIST fs-uae-launcher-3.1.63.tar.xz 7718940 BLAKE2B e1e6102ce6f3e0a5b3f7429ac5894a50b42f2ee26d3b8bf4fec5b39fa199a28d12ebd056ac0c372ce38f78c820dc0c3dec4c4af0918f3a7e5f4b05f944791afb SHA512 d363512c4930f0a245d5333bb5324264244ffc0eb3a39e4ec419cb4861ca9bf5e1f2084405b7f8757f86f0ed9754dbbbbe0aab3391b04898a7d3dc2621346849
DIST fs-uae-launcher-3.1.64.tar.xz 7719268 BLAKE2B 7753006e40e11d557f9cca90296b189638b832b8c2caebceb3fd5aa0393d3b1236ef2d47b176a900d26ab37012198afeb1549da92ba0570eb9b61df42c896550 SHA512 2f7c485f7707595a847130ebbaad3cf1fe9dc11149744bad2683b1b912a53830b687c0aa5ce97dc95a883182ef51020cc02fa434eac903752530f3780342090a
+DIST fs-uae-launcher-3.1.66.tar.xz 7730328 BLAKE2B 68e141658d267c0bc574b216be5c99d10dff23d153e13cccc6a19c5abe618657ce3faf5c685e604ef55927a0dc713c0606f9e1f41e3bcd0015aeb232b9266713 SHA512 6232f43a0a41e67d912b277294079608808a7243512e7970900fab2be483ba82da99eaae547c41be059828c1f5d316e9b58ab8018651c9643b2b72cf7eb6f67e
diff --git a/app-emulation/fs-uae-launcher/fs-uae-launcher-3.1.66.ebuild b/app-emulation/fs-uae-launcher/fs-uae-launcher-3.1.66.ebuild
new file mode 100644
index 000000000000..79ca9670131e
--- /dev/null
+++ b/app-emulation/fs-uae-launcher/fs-uae-launcher-3.1.66.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1 xdg
+
+DESCRIPTION="PyQt5-based launcher for FS-UAE"
+HOMEPAGE="https://fs-uae.net/"
+SRC_URI="https://fs-uae.net/files/FS-UAE-Launcher/Stable/${PV}/${P}.tar.xz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="lha"
+RESTRICT="test" # The test files are just boilerplate.
+
+RDEPEND="
+ app-emulation/fs-uae
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[${PYTHON_USEDEP},declarative,gui,network,opengl,widgets]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ lha? ( dev-python/python-lhafile[${PYTHON_USEDEP}] )
+ ')
+"
+
+BDEPEND="
+ sys-devel/gettext
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.0-ROMs.patch
+)
+
+python_compile_all() {
+ emake
+}
+
+python_install() {
+ local dir=${EPREFIX}/usr/share/${PN}
+ distutils-r1_python_install --install-lib="${dir}" --install-scripts="${dir}"
+}
+
+python_install_all() {
+ dosym ../share/${PN}/${PN} /usr/bin/${PN}
+ emake install-data DESTDIR="${D}" prefix="${EPREFIX}"/usr
+ mv "${ED}"/usr/share/doc/{${PN},${PF}} || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "Some important information:"
+ elog
+ ewarn " - Do not use QtCurve, it will crash PyQt5!"
+ elog
+ elog " - By default, FS-UAE creates its directories under Documents/FS-UAE."
+ elog " If your Documents directory is not configured according to the XDG"
+ elog " user diretory spec, ~/FS-UAE will be used as a fallback."
+ elog
+ elog " - You can override this by putting the path to the desired base"
+ elog " directory in a special config file. The config file will be read"
+ elog " from ~/.config/fs-uae/base-dir by both FS-UAE and FS-UAE Launcher"
+ elog " if it exists."
+ elog
+ elog " Alternatively, you can start FS-UAE and/or FS-UAE Launcher with"
+ elog " --base-dir=/path/to/desired/dir"
+}