summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-27 18:39:55 -0700
committerMatt Turner <mattst88@gentoo.org>2021-06-03 18:14:04 -0700
commit327211ee43ca818aee1d4ae8420e28aa30773d8f (patch)
tree63375d8c940e3288332a1fff1d0162e17469a735 /app-emulation/gallium-nine-standalone
parentapp-crypt/libsecret: Switch to meson-multilib (diff)
downloadgentoo-327211ee43ca818aee1d4ae8420e28aa30773d8f.tar.gz
gentoo-327211ee43ca818aee1d4ae8420e28aa30773d8f.tar.bz2
gentoo-327211ee43ca818aee1d4ae8420e28aa30773d8f.zip
app-emulation/gallium-nine-standalone: Switch to meson-multilib
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-emulation/gallium-nine-standalone')
-rw-r--r--app-emulation/gallium-nine-standalone/gallium-nine-standalone-0.7.ebuild10
-rw-r--r--app-emulation/gallium-nine-standalone/gallium-nine-standalone-0.8.ebuild25
-rw-r--r--app-emulation/gallium-nine-standalone/gallium-nine-standalone-9999.ebuild25
3 files changed, 3 insertions, 57 deletions
diff --git a/app-emulation/gallium-nine-standalone/gallium-nine-standalone-0.7.ebuild b/app-emulation/gallium-nine-standalone/gallium-nine-standalone-0.7.ebuild
index a221e90f1e4b..ca5620c08868 100644
--- a/app-emulation/gallium-nine-standalone/gallium-nine-standalone-0.7.ebuild
+++ b/app-emulation/gallium-nine-standalone/gallium-nine-standalone-0.7.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit meson multilib-minimal toolchain-funcs
+inherit meson-multilib toolchain-funcs
MY_PN="wine-nine-standalone"
DESCRIPTION="A standalone version of the WINE parts of Gallium Nine"
@@ -87,14 +87,6 @@ multilib_src_configure() {
meson_src_configure
}
-multilib_src_compile() {
- meson_src_compile
-}
-
-multilib_src_install() {
- meson_src_install
-}
-
pkg_postinst() {
local bits=$(bits)
diff --git a/app-emulation/gallium-nine-standalone/gallium-nine-standalone-0.8.ebuild b/app-emulation/gallium-nine-standalone/gallium-nine-standalone-0.8.ebuild
index 38dfeb8e3b79..d995a9f7258f 100644
--- a/app-emulation/gallium-nine-standalone/gallium-nine-standalone-0.8.ebuild
+++ b/app-emulation/gallium-nine-standalone/gallium-nine-standalone-0.8.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit meson multilib-minimal toolchain-funcs
+inherit meson-multilib toolchain-funcs
MY_PN="wine-nine-standalone"
DESCRIPTION="A standalone version of the WINE parts of Gallium Nine"
@@ -85,26 +85,3 @@ multilib_src_configure() {
)
meson_src_configure
}
-
-multilib_src_compile() {
- meson_src_compile
-}
-
-multilib_src_install() {
- meson_src_install
-}
-
-pkg_postinst() {
- local bits=$(bits)
-
- einfo "Don't remove the Z: drive from your WINEPREFIX as this relies on it."
- einfo
- einfo "To set up the ${bits}-bit library, launch your preferred Wine as follows:"
- einfo " wine${bits/32} ${EPREFIX}/usr/$(get_libdir)/ninewinecfg.exe.so"
-
- if use abi_x86_64 && use abi_x86_32; then
- einfo
- einfo "To set up the 32-bit library, launch your preferred Wine as follows:"
- einfo " wine ${EPREFIX}/usr/$(ABI=x86 get_libdir)/ninewinecfg.exe.so"
- fi
-}
diff --git a/app-emulation/gallium-nine-standalone/gallium-nine-standalone-9999.ebuild b/app-emulation/gallium-nine-standalone/gallium-nine-standalone-9999.ebuild
index 38dfeb8e3b79..d995a9f7258f 100644
--- a/app-emulation/gallium-nine-standalone/gallium-nine-standalone-9999.ebuild
+++ b/app-emulation/gallium-nine-standalone/gallium-nine-standalone-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit meson multilib-minimal toolchain-funcs
+inherit meson-multilib toolchain-funcs
MY_PN="wine-nine-standalone"
DESCRIPTION="A standalone version of the WINE parts of Gallium Nine"
@@ -85,26 +85,3 @@ multilib_src_configure() {
)
meson_src_configure
}
-
-multilib_src_compile() {
- meson_src_compile
-}
-
-multilib_src_install() {
- meson_src_install
-}
-
-pkg_postinst() {
- local bits=$(bits)
-
- einfo "Don't remove the Z: drive from your WINEPREFIX as this relies on it."
- einfo
- einfo "To set up the ${bits}-bit library, launch your preferred Wine as follows:"
- einfo " wine${bits/32} ${EPREFIX}/usr/$(get_libdir)/ninewinecfg.exe.so"
-
- if use abi_x86_64 && use abi_x86_32; then
- einfo
- einfo "To set up the 32-bit library, launch your preferred Wine as follows:"
- einfo " wine ${EPREFIX}/usr/$(ABI=x86 get_libdir)/ninewinecfg.exe.so"
- fi
-}