summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-02-13 23:19:45 +0000
committerJames Le Cuirot <chewi@gentoo.org>2021-02-13 23:19:45 +0000
commitbc83e36e0f2d76fd4be83f5b210d414d706156f0 (patch)
tree3751cb3615424bef1632b7c22d20b9e3a596b6d3 /app-emulation/gallium-nine-standalone
parentmedia-libs/lasi: Add missing die in 1.1.3 (diff)
downloadgentoo-bc83e36e0f2d76fd4be83f5b210d414d706156f0.tar.gz
gentoo-bc83e36e0f2d76fd4be83f5b210d414d706156f0.tar.bz2
gentoo-bc83e36e0f2d76fd4be83f5b210d414d706156f0.zip
app-emulation/gallium-nine-standalone: Upstream patch about libwine
Bug: https://github.com/iXit/wine-nine-standalone/issues/92 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'app-emulation/gallium-nine-standalone')
-rw-r--r--app-emulation/gallium-nine-standalone/files/0.7-no-libwine.patch34
-rw-r--r--app-emulation/gallium-nine-standalone/gallium-nine-standalone-0.7.ebuild3
2 files changed, 36 insertions, 1 deletions
diff --git a/app-emulation/gallium-nine-standalone/files/0.7-no-libwine.patch b/app-emulation/gallium-nine-standalone/files/0.7-no-libwine.patch
new file mode 100644
index 000000000000..abcf7ad4ea3b
--- /dev/null
+++ b/app-emulation/gallium-nine-standalone/files/0.7-no-libwine.patch
@@ -0,0 +1,34 @@
+From bddb53abdd1a77b1c019457f7eea4a6404a5e492 Mon Sep 17 00:00:00 2001
+From: Andre Heider <a.heider@gmail.com>
+Date: Sun, 17 Jan 2021 11:42:57 +0100
+Subject: [PATCH] meson: stop checking for libwine
+
+From the WINE 6.0 release notes:
+The libwine library is no longer used, but it's still provided to
+support running Winelib modules built against older versions. It is
+deprecated however, and will be removed in a future Wine release.
+
+libwine wasn't used anymore anyway, this just ensures that this tree can
+be built against future WINE versions.
+---
+ meson.build | 4 +---
+ 1 file changed, 1 insertion(+), 3 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 0969777..47ee51a 100644
+--- a/meson.build
++++ b/meson.build
+@@ -35,12 +35,10 @@ code = '''#ifndef __WINE__
+ #error 1
+ #endif'''
+
+-if not cc.compiles(code, name: 'winelib check')
++if not cc.compiles(code, name: 'winegcc check')
+ error('A WINE cross compiler is required')
+ endif
+
+-dep_wine = cc.find_library('wine')
+-
+ if not cc.has_header_symbol('windows.h', 'wine_get_unix_file_name')
+ error('WINE headers not found')
+ endif
diff --git a/app-emulation/gallium-nine-standalone/gallium-nine-standalone-0.7.ebuild b/app-emulation/gallium-nine-standalone/gallium-nine-standalone-0.7.ebuild
index 3e96326a2fc8..ea3ad385cab5 100644
--- a/app-emulation/gallium-nine-standalone/gallium-nine-standalone-0.7.ebuild
+++ b/app-emulation/gallium-nine-standalone/gallium-nine-standalone-0.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -38,6 +38,7 @@ DEPEND="
"
PATCHES=(
+ "${FILESDIR}"/0.7-no-libwine.patch
"${FILESDIR}"/0.7-cross-files.patch
"${FILESDIR}"/0.3-nine-dll-path.patch
)