summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-04-25 06:23:27 +0200
committerJeroen Roovers <jer@gentoo.org>2017-04-25 06:23:27 +0200
commite737d4a2836be6079b9130724af84e4059089837 (patch)
treed7c38504605a3de1f9f1063dd131df12308d72cf /app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.16.ebuild
parentdev-util/debootstrap: Version bump. (diff)
downloadgentoo-e737d4a2836be6079b9130724af84e4059089837.tar.gz
gentoo-e737d4a2836be6079b9130724af84e4059089837.tar.bz2
gentoo-e737d4a2836be6079b9130724af84e4059089837.zip
app-emulation/ganeti-instance-debootstrap: Version bump (bug #598497).
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.16.ebuild')
-rw-r--r--app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.16.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.16.ebuild b/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.16.ebuild
new file mode 100644
index 000000000000..7bea16989fde
--- /dev/null
+++ b/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.16.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="Scripts to build Ganeti VMs with debootstrap"
+HOMEPAGE="http://www.ganeti.org/"
+SRC_URI="http://downloads.ganeti.org/instance-debootstrap/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ ${DEPEND}
+ >=sys-apps/coreutils-6.10-r1
+ app-arch/dpkg
+ app-arch/dump
+ app-emulation/ganeti
+ dev-util/debootstrap
+ sys-apps/util-linux
+ sys-fs/e2fsprogs
+ sys-fs/multipath-tools
+"
+
+src_prepare() {
+ default
+
+ sed -i -e 's|AC_MSG_ERROR|AC_MSG_WARN|g' configure.ac || die
+ sed -i -e 's|COPYING||g' Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --docdir=/usr/share/doc/${P}
+}
+
+src_install() {
+ default
+
+ insinto /etc/ganeti/instance-debootstrap/hooks
+ doins examples/hooks/*
+}