summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-06-14 13:12:33 -0700
committerPatrick McLean <chutzpah@gentoo.org>2019-06-14 13:12:33 -0700
commitd2069f8befb036f13a2f366b33615952483973e9 (patch)
tree270583f568c5e212e6781c29cb9e76a2a26a2ee2 /app-emulation/ganeti-instance-image/ganeti-instance-image-0.6-r2.ebuild
parentdev-util/shards: bump up to 0.9.0 (diff)
downloadgentoo-d2069f8befb036f13a2f366b33615952483973e9.tar.gz
gentoo-d2069f8befb036f13a2f366b33615952483973e9.tar.bz2
gentoo-d2069f8befb036f13a2f366b33615952483973e9.zip
app-emulation/ganeti-instance-image: Revbump to 0.6-r2 (bug #687974)
Drop patch that was added in 0.6-r1. Closes: https://bugs.gentoo.org/687974 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-emulation/ganeti-instance-image/ganeti-instance-image-0.6-r2.ebuild')
-rw-r--r--app-emulation/ganeti-instance-image/ganeti-instance-image-0.6-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-emulation/ganeti-instance-image/ganeti-instance-image-0.6-r2.ebuild b/app-emulation/ganeti-instance-image/ganeti-instance-image-0.6-r2.ebuild
new file mode 100644
index 000000000000..9e62e96a8908
--- /dev/null
+++ b/app-emulation/ganeti-instance-image/ganeti-instance-image-0.6-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://git.osuosl.org/${PN}.git"
+ EGIT_BRANCH="master"
+ inherit git-r3 autotools
+else
+ SRC_URI="http://ftp.osuosl.org/pub/osl/ganeti-instance-image/${P}.tar.gz"
+fi
+
+DESCRIPTION="Scripts to build out CD or image based VMs using Ganeti"
+HOMEPAGE="http://code.osuosl.org/projects/ganeti-image"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-arch/dump
+ >=app-emulation/ganeti-2.15.2-r7
+ app-emulation/qemu
+ sys-apps/util-linux
+ sys-fs/multipath-tools
+ sys-fs/e2fsprogs"
+
+src_prepare() {
+ default
+ if [[ ${PV} == "9999" ]]; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf --with-default-dir=/etc/ganeti
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ rm -rf "${D}"/usr/share/doc/${PN}
+ dodoc README.markdown NEWS ChangeLog
+ insinto /etc/ganeti
+ newins defaults ${PN}
+}